summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-dateutil/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-dateutil/files')
-rw-r--r--dev-python/python-dateutil/files/python-dateutil-1.4.1-locale.patch13
-rw-r--r--dev-python/python-dateutil/files/python-dateutil-2.1-open-utf-8.patch21
-rw-r--r--dev-python/python-dateutil/files/python-dateutil-2.4.2-timelex.patch13
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-dateutil/files/python-dateutil-1.4.1-locale.patch b/dev-python/python-dateutil/files/python-dateutil-1.4.1-locale.patch
new file mode 100644
index 000000000000..53d4bb868302
--- /dev/null
+++ b/dev-python/python-dateutil/files/python-dateutil-1.4.1-locale.patch
@@ -0,0 +1,13 @@
+Index: python-dateutil/example.py
+===================================================================
+--- python-dateutil.orig/example.py 2006-09-06 13:21:44.000000000 +0200
++++ python-dateutil/example.py 2006-09-06 13:21:56.000000000 +0200
+@@ -5,7 +5,7 @@
+ from datetime import *
+ import commands
+ import os
+-now = parse(commands.getoutput("date"))
++now = parse(commands.getoutput("LC_ALL=C date"))
+ today = now.date()
+ year = rrule(YEARLY,bymonth=8,bymonthday=13,byweekday=FR)[0].year
+ rdelta = relativedelta(easter(year), today)
diff --git a/dev-python/python-dateutil/files/python-dateutil-2.1-open-utf-8.patch b/dev-python/python-dateutil/files/python-dateutil-2.1-open-utf-8.patch
new file mode 100644
index 000000000000..f27285428784
--- /dev/null
+++ b/dev-python/python-dateutil/files/python-dateutil-2.1-open-utf-8.patch
@@ -0,0 +1,21 @@
+Fix UnicodeDecodeError in setup.py.
+
+https://bugs.gentoo.org/show_bug.cgi?id=410725
+--- setup.py
++++ setup.py
+@@ -1,5 +1,6 @@
+ #!/usr/bin/python
+ from os.path import isfile, join
++import codecs
+ import glob
+ import os
+ import re
+@@ -13,7 +14,7 @@
+
+ TOPDIR = os.path.dirname(__file__) or "."
+ VERSION = re.search('__version__ = "([^"]+)"',
+- open(TOPDIR + "/dateutil/__init__.py").read()).group(1)
++ codecs.open(TOPDIR + "/dateutil/__init__.py", encoding='utf-8').read()).group(1)
+
+
+ setup(name="python-dateutil",
diff --git a/dev-python/python-dateutil/files/python-dateutil-2.4.2-timelex.patch b/dev-python/python-dateutil/files/python-dateutil-2.4.2-timelex.patch
new file mode 100644
index 000000000000..bccec4a56ddc
--- /dev/null
+++ b/dev-python/python-dateutil/files/python-dateutil-2.4.2-timelex.patch
@@ -0,0 +1,13 @@
+diff --git dateutil/parser.py~ dateutil/parser.py
+index 8b6c2d28b8..75453ef49e 100644
+--- dateutil/parser.py~
++++ dateutil/parser.py
+@@ -32,7 +32,7 @@ __all__ = ["parse", "parserinfo"]
+ class _timelex(object):
+
+ def __init__(self, instream):
+- if isinstance(instream, text_type):
++ if not hasattr(instream, 'read'):
+ instream = StringIO(instream)
+ self.instream = instream
+ self.wordchars = ('abcdfeghijklmnopqrstuvwxyz'