summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-30 14:24:18 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-30 14:34:54 +0100
commitd0ca77b22cf451c9260994203b5531aa28eb6a1c (patch)
treeb13fddfc50e2c531f80cf30a6f67fc1c3db184d6 /dev-python/python-dbusmock
parentdev-python/construct: Bump to 2.10.70 (diff)
downloadgentoo-d0ca77b22cf451c9260994203b5531aa28eb6a1c.tar.gz
gentoo-d0ca77b22cf451c9260994203b5531aa28eb6a1c.tar.bz2
gentoo-d0ca77b22cf451c9260994203b5531aa28eb6a1c.zip
dev-python/python-dbusmock: Bump to 0.30.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest1
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.30.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index 358e2051db78..947788871011 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1 +1,2 @@
DIST python-dbusmock-0.29.1.tar.gz 92555 BLAKE2B 64888de1a6b99698a36be357cad56f7d0f646a2ddb67825b37f5a9241a90dc7d4df6f0de42abc471ec10e10e9166e0b8b3d17f4e6277f2e54836cd01968dfe61 SHA512 722002838a983bbe908192ed1cae715066f509f33bd3b9bff8075d8f2d75c41b57e89bc7d76af2591d815f244b604671fa45030a52499a369d2cf23842fa4e88
+DIST python-dbusmock-0.30.0.tar.gz 98201 BLAKE2B eb519dc526d4e3ab804c3415d223d77462e944bac8d03dd64fbe11f8a5d875ebad1643230b93d1d51cd4a979eed24e6b97d0744b115d28d233b4d1239ec04f01 SHA512 280a8ebfe12a0f5b309d5b807547ed521c80c9899fdc89abaaee238621cf94d05f8413ab2908ca331f9d3ef1c610234dafbd912f8590f18c7d9cafe470beece6
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.30.0.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.30.0.ebuild
new file mode 100644
index 000000000000..51ed224162c1
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.30.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}