summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-22 00:21:11 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-22 00:50:08 +0200
commitf90854c5ca2e1cf350298518f42d8e9309bf1dfb (patch)
treef28045fda56e59b1a4baadc9b8ad939f99316534 /dev-python/python-docs
parentdev-python/python-docs: Remove old (diff)
downloadgentoo-f90854c5ca2e1cf350298518f42d8e9309bf1dfb.tar.gz
gentoo-f90854c5ca2e1cf350298518f42d8e9309bf1dfb.tar.bz2
gentoo-f90854c5ca2e1cf350298518f42d8e9309bf1dfb.zip
dev-python/python-docs: Bump to 3.8.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/Manifest1
-rw-r--r--dev-python/python-docs/python-docs-3.8.6.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-docs/Manifest b/dev-python/python-docs/Manifest
index d21f0f277836..a1ce6039f841 100644
--- a/dev-python/python-docs/Manifest
+++ b/dev-python/python-docs/Manifest
@@ -2,3 +2,4 @@ DIST python-2.7.18-docs-html.tar.bz2 4634932 BLAKE2B c48e2dede15d8186231acf65709
DIST python-3.6.12-docs-html.tar.bz2 6013089 BLAKE2B dc1c9f702bdd8be619c3cd6fd0f8cab022b8d7542ace7a7b7f63b9642f693c63b036f03248cf7ea0108ab7e33655379ca906c8ef7c35d8242517ead721a83778 SHA512 da28da84f5e8f889f328fafb4d17beb6cfc52c5703bcf5080cfbaea552f414d6f0a682aaacb2f04fa32e9453a1bdaae8ff108c38a4486170bd0edf1efacafdf7
DIST python-3.7.9-docs-html.tar.bz2 6285801 BLAKE2B bc76a90bed3f9126a63fc76bc7ec858b90dcf827eb0af19652ee987aa3feeef9de71be0e14b33f98ee5733b9eeecd3d6ec01837fcbab31d505e389ea99d6fd0a SHA512 243327bdcb85b696fccf20b3cb841b398a672f07e34f441323418651ead58ab3346eff39e78501130b5d97e5d87fb72c945a9c4b9082b26577f33bd095791d55
DIST python-3.8.5-docs-html.tar.bz2 6562020 BLAKE2B 29a375c0b0be6bedc7d52c15e038b1d150940a0b6185490bdacbce5822c6e88c49124a293a85ea2c08642fcdb99625986ec26ca1d712184988e02729f35e17aa SHA512 db9cc21223bc3b3126140e30c7731152816c61fdb647787c64e138ec882838dbc69fce8a4012ba389bc8efebdb2e0efb5e1b0a6cd652a8b9ad20bb021b277de7
+DIST python-3.8.6-docs-html.tar.bz2 6578280 BLAKE2B efdc62b2d570cbe7e69be1cf118250ee89f1b09af7e7db306970e764dcc9e6f20bda9230fe934ecc0891a1d79370294bc42170713b9471d05f23a468f09015fc SHA512 be0d61a9556fbdd24ab124cfdf220b3bdb537cc02d5896f8f4c75cb73e3cfd5c2947c060d049b57bf5576b4b2d1c7f0f3987070d70ce883dea023e1feab1a630
diff --git a/dev-python/python-docs/python-docs-3.8.6.ebuild b/dev-python/python-docs/python-docs-3.8.6.ebuild
new file mode 100644
index 000000000000..16f1d2327d67
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.8.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}