summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-04-30 00:38:11 +0200
committerSebastian Pipping <sping@gentoo.org>2021-04-30 02:26:33 +0200
commitbb5efcb600c590d49006f1b5d3593809534ba74e (patch)
tree71463704146c64cdd5f5c031526e8dbd8ec583e4 /dev-python/python-dotenv/python-dotenv-0.17.1.ebuild
parentx11-misc/safeeyes: 2.1.3 (diff)
downloadgentoo-bb5efcb600c590d49006f1b5d3593809534ba74e.tar.gz
gentoo-bb5efcb600c590d49006f1b5d3593809534ba74e.tar.bz2
gentoo-bb5efcb600c590d49006f1b5d3593809534ba74e.zip
dev-python/python-dotenv: 0.17.1 + fix tests
Closes: https://bugs.gentoo.org/786579 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.18, Repoman-3.0.3
Diffstat (limited to 'dev-python/python-dotenv/python-dotenv-0.17.1.ebuild')
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.17.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-dotenv/python-dotenv-0.17.1.ebuild b/dev-python/python-dotenv/python-dotenv-0.17.1.ebuild
new file mode 100644
index 000000000000..400dad458bc2
--- /dev/null
+++ b/dev-python/python-dotenv/python-dotenv-0.17.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Manage .env files"
+HOMEPAGE="https://github.com/theskumar/python-dotenv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ test? (
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sh-1.09[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests --install pytest