summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-27 00:29:12 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-27 00:42:58 -0600
commit52c7e3adb51fde935febb063ca0a74f38889bf9d (patch)
tree977962071ccb67239fc34731951638712949155a /dev-python/python-saharaclient
parentdev-python/python-manilaclient: bup (diff)
downloadgentoo-52c7e3adb51fde935febb063ca0a74f38889bf9d.tar.gz
gentoo-52c7e3adb51fde935febb063ca0a74f38889bf9d.tar.bz2
gentoo-52c7e3adb51fde935febb063ca0a74f38889bf9d.zip
dev-python/python-saharaclient: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/python-saharaclient')
-rw-r--r--dev-python/python-saharaclient/Manifest1
-rw-r--r--dev-python/python-saharaclient/python-saharaclient-1.1.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/python-saharaclient/Manifest b/dev-python/python-saharaclient/Manifest
index 39b25ffc5b8b..663bc07e8fd4 100644
--- a/dev-python/python-saharaclient/Manifest
+++ b/dev-python/python-saharaclient/Manifest
@@ -1 +1,2 @@
DIST python-saharaclient-0.11.0.tar.gz 101842 SHA256 0c08bcc7d490a9133ecc261bc8b270f3a4187952b19aa375e59a460491dc40bd SHA512 de30918d23b5b8191b2e49f0f7116510533da15be412d87c9018af2e4144082e9cb127713a4aff3ac03d72867a9855d73cbd56b83db24a9bad9b7b422c451018 WHIRLPOOL 97cd3f7b90f96d010d2f267c7ae593ea9c492a4b75c048596b53f1083dd57027dd79b3f0acb3708536ce1bba2ef3ae1afe4eada22355c7c8792164652a7fbc79
+DIST python-saharaclient-1.1.0.tar.gz 81664 SHA256 cb9c07f8131927886fd17b9c28e33f1aa840db1aac82e120ae531807638b1e80 SHA512 0799549d68bc65792cdf0129f3590667a1a87697182ad24c5c41e9c01abf5e133a16a60fe0331f313da44017aaf0503bbc131e8a62536a692032af36ae9f1386 WHIRLPOOL 6aa4aecff6c97cc432a6c192762ae9e8a5d56567579ca4425c236db3f746d438a57aa320544c16459be6bd750ca0bc5404851d256cfea20a5e2dced8a485a6bd
diff --git a/dev-python/python-saharaclient/python-saharaclient-1.1.0.ebuild b/dev-python/python-saharaclient/python-saharaclient-1.1.0.ebuild
new file mode 100644
index 000000000000..87c6eb6a3071
--- /dev/null
+++ b/dev-python/python-saharaclient/python-saharaclient-1.1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client for the OpenStack Sahara API, aka HADOOP"
+HOMEPAGE="https://github.com/openstack/python-saharaclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/os-testr-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.11.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testr init
+ testr run --parallel || die "testsuite failed under python2.7"
+}