summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-24 21:32:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-24 22:05:04 +0200
commitccb43d174a5590cb014aa98bbc2d0f3bfe926a3b (patch)
treedd4c8d356a136fe8cce7e45149a0539c7ca24ece /dev-python/rich
parentdev-python/rich: Remove old (diff)
downloadgentoo-ccb43d174a5590cb014aa98bbc2d0f3bfe926a3b.tar.gz
gentoo-ccb43d174a5590cb014aa98bbc2d0f3bfe926a3b.tar.bz2
gentoo-ccb43d174a5590cb014aa98bbc2d0f3bfe926a3b.zip
dev-python/rich: Bump to 10.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-10.11.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 8e43578a3e0f..0fc9352eaecc 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1 +1,2 @@
DIST rich-10.10.0.tar.gz 16264680 BLAKE2B 5f57b7ea7a091b3478ddc17dfe29309f558f36e8795a66ea918141f42f2a9e5a655667a1db8420193f3f44ba070413ebb512601751a6a5663a87db775576ce65 SHA512 8b9f1348b0f55db90c17042a83e8317d4f00b5446a77334a12379676ef1fe526f40dc92425e4bafce22ee5f65bcb2fae2422b903c6f958feb5734c254813826e
+DIST rich-10.11.0.tar.gz 16266050 BLAKE2B 34081a127eacbc875fb5af1b00a195df4718eacb4e0371ac1367950fc8e102bc2a611d970364a1b02cb400137cb838aa30d9bcd757a4d4644ed976c49c9603c8 SHA512 34cdcad401dbda0763dfaa6f46e19e498b2da96ed9423a00a957d55f9e2833fabc6b2e6d65e411dcb5814c869a8670b5242e1a891835d6b6675d4da86b28f33d
diff --git a/dev-python/rich/rich-10.11.0.ebuild b/dev-python/rich/rich-10.11.0.ebuild
new file mode 100644
index 000000000000..a18af32f8dc0
--- /dev/null
+++ b/dev-python/rich/rich-10.11.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}