summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-20 00:09:02 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-20 00:13:56 +0200
commitb0c925b7058fbea4262328cb42093472b78a7527 (patch)
tree7de3c93c348bd7745ee195fcc1b8521aeadc0a0a /dev-python/ruamel-yaml
parentdev-python/translate-toolkit: Bump to 3.4.0 (diff)
downloadgentoo-b0c925b7058fbea4262328cb42093472b78a7527.tar.gz
gentoo-b0c925b7058fbea4262328cb42093472b78a7527.tar.bz2
gentoo-b0c925b7058fbea4262328cb42093472b78a7527.zip
dev-python/ruamel-yaml: Bump to 0.17.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-yaml')
-rw-r--r--dev-python/ruamel-yaml/Manifest1
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.11.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index 1287d758d894..7af41ae70c9f 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -1 +1,2 @@
DIST ruamel-yaml-0.17.10.tar.xz 183116 BLAKE2B 2795f470a3f7da609780109dfac502a5b47184f465c68420f467209275c8857418a4ec7424e130df2e7acef614d93f91551910eceb06cd9e49b365bb23d2a015 SHA512 3cd2598fa37564c44c74720e72babcd2252b2dbcdde626bdcf771b591da5d2852d90bb1f22428e28cd7ec38304be2a437aa0569ffbd3ebb526b2b79a955bc88d
+DIST ruamel.yaml-0.17.11.tar.xz 183476 BLAKE2B 02a1693d3a20f44b7f82668918a53d06f9fa5c0cff6f149fe51de3fbb3551e823f3a7a2f0f4e818f43e2974eaf95c4219d53738bad78544c6bb1f19d85457715 SHA512 8f24b33592c37fd1d370cb6367a3652e72df3d88c7a14fff187aaa8622b9bbd77e780193fcd920916eca7f627dd37c87eb9b987d091c944ff08ef25ee4567b45
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.11.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.11.ebuild
new file mode 100644
index 000000000000..f87789872e5e
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/p/ruamel-yaml/"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/namespace-ruamel[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+# Old PyYAML tests from lib/ require special set-up and are invoked indirectly
+# via test_z_olddata, tell pytest itself to leave the subdir alone.
+python_test() {
+ local deselect=()
+
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+
+ epytest --ignore _test/lib/ ${deselect[@]/#/--deselect }
+}
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}