summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-19 19:29:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-19 19:42:48 +0200
commit50a68a4760d3e65dfd19ad366e4b4fc6ca239701 (patch)
treebbca6e1011f988df84f27818c57b58a2f967a965 /dev-python/scikit-build
parentdev-java/javatoolkit: bump to 0.6.6 (diff)
downloadgentoo-50a68a4760d3e65dfd19ad366e4b4fc6ca239701.tar.gz
gentoo-50a68a4760d3e65dfd19ad366e4b4fc6ca239701.tar.bz2
gentoo-50a68a4760d3e65dfd19ad366e4b4fc6ca239701.zip
dev-python/scikit-build: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/files/scikit-build-0.11.1-py310.patch28
-rw-r--r--dev-python/scikit-build/scikit-build-0.11.1.ebuild9
2 files changed, 34 insertions, 3 deletions
diff --git a/dev-python/scikit-build/files/scikit-build-0.11.1-py310.patch b/dev-python/scikit-build/files/scikit-build-0.11.1-py310.patch
new file mode 100644
index 000000000000..fa00556f9add
--- /dev/null
+++ b/dev-python/scikit-build/files/scikit-build-0.11.1-py310.patch
@@ -0,0 +1,28 @@
+From c1677527af3f7afd48ebbe1b2338ac822f64c524 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 19 Jun 2021 19:27:09 +0200
+Subject: [PATCH] fix: fix regex in test_get_python_version for Python 3.10
+
+Fix the regular expression in test_get_python_version to permit
+the minor version to contain more than one digit. This fixes the test
+on Python 3.10.
+---
+ tests/test_cmaker.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_cmaker.py b/tests/test_cmaker.py
+index d63059c..52d0028 100644
+--- a/tests/test_cmaker.py
++++ b/tests/test_cmaker.py
+@@ -21,7 +21,7 @@ from . import _tmpdir, get_cmakecache_variables
+
+
+ def test_get_python_version():
+- assert re.match(r'^[23](\.?)[0-9]$', CMaker.get_python_version())
++ assert re.match(r'^[23](\.?)\d+$', CMaker.get_python_version())
+
+
+ def test_get_python_include_dir():
+--
+2.32.0
+
diff --git a/dev-python/scikit-build/scikit-build-0.11.1.ebuild b/dev-python/scikit-build/scikit-build-0.11.1.ebuild
index b65c6bdf6891..bbebf508eb95 100644
--- a/dev-python/scikit-build/scikit-build-0.11.1.ebuild
+++ b/dev-python/scikit-build/scikit-build-0.11.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -32,7 +32,10 @@ DEPEND="
dev-python/virtualenv[${PYTHON_USEDEP}]
)"
-PATCHES=( "${FILESDIR}/${PN}-0.10.0-docs.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.10.0-docs.patch"
+ "${FILESDIR}"/${P}-py310.patch
+)
distutils_enable_sphinx docs \
dev-python/sphinx_rtd_theme \