summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-24 14:52:27 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-24 15:02:24 +0200
commit708baee42c100633c9093e805b4d335765fae4e8 (patch)
tree882c6106db81e27b029f8284cdaa07f5716ee210 /dev-python/selenium
parentx11-drivers/nvidia-drivers: use prebuilt egl-gbm (diff)
downloadgentoo-708baee42c100633c9093e805b4d335765fae4e8.tar.gz
gentoo-708baee42c100633c9093e805b4d335765fae4e8.tar.bz2
gentoo-708baee42c100633c9093e805b4d335765fae4e8.zip
dev-python/selenium: Bump to 4.23.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/selenium')
-rw-r--r--dev-python/selenium/Manifest2
-rw-r--r--dev-python/selenium/selenium-4.23.1.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/selenium/Manifest b/dev-python/selenium/Manifest
index 8c751457d45d..273a970fde2e 100644
--- a/dev-python/selenium/Manifest
+++ b/dev-python/selenium/Manifest
@@ -1,2 +1,4 @@
DIST selenium-4.22.0.tar.gz 9242392 BLAKE2B 15197221a53c597b412f805eed7f29f4c34a9d0596a069ea5a6df540b93c013815a59fe1730e8493f5ae854cbc03d5a6647eb57d825ecc68ad0b31949448acaa SHA512 a25c892495ed613c2cd96ab971f46cc101416a4928cffceaa9891c759a41d51df392999495d442a21b459d83a1b287c64c2cd5405b82e16464b56fcc75b2c595
+DIST selenium-4.23.1.tar.gz 945830 BLAKE2B 7931156bc8b79484433cb6a9bd7d49852981e3662a8e75f1f48d683644bac1c78e616e33965c611f50203a6a6f0f5bd09501c16816afe7a7c27b2a9e72a10a14 SHA512 3f9cda92c606ce7a32ecb6f1ef434501368fdab8673a0f23a39d78b80e80b732fafb6e29842ab5301d31cd8eaa907561b91a96cf67e181daeae3378e6a0e9a5b
DIST selenium-selenium-4.22.0.gh.tar.gz 77094998 BLAKE2B 1d74be914debec94e3b9fe41ce40e7432426c7f30a848c63ad82e616fc3dd7dce8e544c33a90e28ca268988b9035aabe41805277085095cc1c65bd38e09117e5 SHA512 f71721b614fa3e346a75ca2391fb03067520d746e1433a75ba896eb6bbe621064bcab7d50337989ccb60d13c493e2df2b3b1bd73cc8dcaf3b62dc4f4ebfaa086
+DIST selenium-selenium-4.23.1-python.gh.tar.gz 77116002 BLAKE2B dad444b109d2494b3442c81187fa6c9d3db2565183304f76d2badf2444e0545727c6f4bf08be0a5102692b9c018b3354a4063758253275624f9f4d6ff6d49254 SHA512 e7d4dc8f14fe9cae3d8e362a03b5068536d64e8484e151187ae9c917350e1f299977fb1521066998fba5cd845c5167a8440d02b15547d066a40d3e79cac1f50d
diff --git a/dev-python/selenium/selenium-4.23.1.ebuild b/dev-python/selenium/selenium-4.23.1.ebuild
new file mode 100644
index 000000000000..93d3dc2bc18b
--- /dev/null
+++ b/dev-python/selenium/selenium-4.23.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" python3_13 )
+
+inherit distutils-r1 pypi
+
+# upstream sometimes tags it as ${P}, sometimes as ${P}-python, sigh
+TEST_TAG=${P}-python
+TEST_P=selenium-${TEST_TAG}
+
+DESCRIPTION="Python language binding for Selenium Remote Control"
+HOMEPAGE="
+ https://www.seleniumhq.org/
+ https://github.com/SeleniumHQ/selenium/tree/trunk/py/
+ https://pypi.org/project/selenium/
+"
+SRC_URI+="
+ test? (
+ https://github.com/SeleniumHQ/selenium/archive/${TEST_TAG}.tar.gz
+ -> ${TEST_P}.gh.tar.gz
+ )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/certifi-2021.10.8[${PYTHON_USEDEP}]
+ <dev-python/trio-1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.17[${PYTHON_USEDEP}]
+ <dev-python/trio-websocket-1[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9[${PYTHON_USEDEP}]
+ <dev-python/typing-extensions-5[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.9[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-2[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.8.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # do not build selenium-manager implicitly
+ sed -e '/setuptools_rust/d' \
+ -e '/rust_extensions/,/\]/d' \
+ -i setup.py || die
+}
+
+python_test() {
+ if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # TODO: we may need extra setup or deps
+ test/selenium
+
+ # expects vanilla certifi
+ test/unit/selenium/webdriver/remote/remote_connection_tests.py::test_get_connection_manager_for_certs_and_timeout
+ )
+
+ cd "${WORKDIR}/${TEST_P}/py" || die
+ rm -rf selenium || die
+ # https://github.com/SeleniumHQ/selenium/blob/selenium-4.8.2-python/py/test/runner/run_pytest.py#L20-L24
+ # seriously?
+ epytest -o "python_files=*_tests.py test_*.py"
+}