summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2021-05-30 17:13:48 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-30 18:53:48 +0200
commit5c46947a8668bec825a57bdcd9074fc91b772407 (patch)
tree06ec2b4c6d20d89b92f106213524cf41156256e2 /dev-python/send2trash
parentdev-perl/File-Path-Expand: Remove old 1.02 r1 (diff)
downloadgentoo-5c46947a8668bec825a57bdcd9074fc91b772407.tar.gz
gentoo-5c46947a8668bec825a57bdcd9074fc91b772407.tar.bz2
gentoo-5c46947a8668bec825a57bdcd9074fc91b772407.zip
dev-python/send2trash: Bump to python 3.10 and removed the old patch
The patch is needed only for python 2 which is not supported anymore Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/send2trash')
-rw-r--r--dev-python/send2trash/files/send2trash-1.5.0-fix-broken-tests-on-py2.patch29
-rw-r--r--dev-python/send2trash/send2trash-1.5.0-r1.ebuild10
2 files changed, 3 insertions, 36 deletions
diff --git a/dev-python/send2trash/files/send2trash-1.5.0-fix-broken-tests-on-py2.patch b/dev-python/send2trash/files/send2trash-1.5.0-fix-broken-tests-on-py2.patch
deleted file mode 100644
index 3f2a64ca2a21..000000000000
--- a/dev-python/send2trash/files/send2trash-1.5.0-fix-broken-tests-on-py2.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 74352462f5df2cb5708b96458b81afef3070c800 Mon Sep 17 00:00:00 2001
-From: Virgil Dupras <hsoft@hardcoded.net>
-Date: Thu, 26 Jul 2018 08:30:39 -0400
-Subject: [PATCH] Fix broken tests on py2
-
----
- tests/test_plat_other.py | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/tests/test_plat_other.py b/tests/test_plat_other.py
-index b94295d..ae4f391 100644
---- a/tests/test_plat_other.py
-+++ b/tests/test_plat_other.py
-@@ -6,7 +6,11 @@ from os import path as op
- import send2trash.plat_other
- from send2trash.plat_other import send2trash as s2t
- from send2trash.compat import PY3
--from configparser import ConfigParser
-+try:
-+ from configparser import ConfigParser
-+except ImportError:
-+ # py2
-+ from ConfigParser import ConfigParser
- from tempfile import mkdtemp, NamedTemporaryFile, mktemp
- import shutil
- import stat
---
-2.16.4
-
diff --git a/dev-python/send2trash/send2trash-1.5.0-r1.ebuild b/dev-python/send2trash/send2trash-1.5.0-r1.ebuild
index e784dc366bd0..7e7a2b9a85aa 100644
--- a/dev-python/send2trash/send2trash-1.5.0-r1.ebuild
+++ b/dev-python/send2trash/send2trash-1.5.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -21,8 +21,4 @@ SLOT="0"
LICENSE="BSD"
KEYWORDS="amd64 ~arm64 x86"
-distutils_enable_tests setup.py
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-broken-tests-on-py2.patch"
-)
+distutils_enable_tests pytest