summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-12-25 20:12:55 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-12-25 20:12:58 +0100
commit3d1eb1ce4d73e253edf3f9005859fb217a80ddbb (patch)
tree29d8e9d565e6101c43798740e05bd4c3a8d36e3b /dev-python/sense-hat/sense-hat-2.6.0.ebuild
parentdev-python/python-sense-hat: movepkg to dev-python/sense-hat (diff)
downloadgentoo-3d1eb1ce4d73e253edf3f9005859fb217a80ddbb.tar.gz
gentoo-3d1eb1ce4d73e253edf3f9005859fb217a80ddbb.tar.bz2
gentoo-3d1eb1ce4d73e253edf3f9005859fb217a80ddbb.zip
dev-python/sense-hat: add 2.6.0
Closes: https://bugs.gentoo.org/920647 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/sense-hat/sense-hat-2.6.0.ebuild')
-rw-r--r--dev-python/sense-hat/sense-hat-2.6.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/sense-hat/sense-hat-2.6.0.ebuild b/dev-python/sense-hat/sense-hat-2.6.0.ebuild
new file mode 100644
index 000000000000..e628fd7360e8
--- /dev/null
+++ b/dev-python/sense-hat/sense-hat-2.6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+MY_PN="python-${PN}"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Raspberry Pi Sense HAT python library"
+HOMEPAGE="https://github.com/astro-pi/python-sense-hat"
+SRC_URI="https://github.com/astro-pi/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~arm ~arm64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/rtimulib[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"