summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-21 12:32:27 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-21 12:34:13 +0100
commitf7cb2551a3ab69a79e7a92da3df8ee020abf6758 (patch)
tree5ce3aebac4df48d52fb5b7ebe886bec57a71d2d6 /dev-python/six/six-1.16.0-r1.ebuild
parentdev-ml/dune-configurator: add 3.17.1 (diff)
downloadgentoo-f7cb2551a3ab69a79e7a92da3df8ee020abf6758.tar.gz
gentoo-f7cb2551a3ab69a79e7a92da3df8ee020abf6758.tar.bz2
gentoo-f7cb2551a3ab69a79e7a92da3df8ee020abf6758.zip
dev-python/six: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/six/six-1.16.0-r1.ebuild')
-rw-r--r--dev-python/six/six-1.16.0-r1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/six/six-1.16.0-r1.ebuild b/dev-python/six/six-1.16.0-r1.ebuild
deleted file mode 100644
index d7f93534815a..000000000000
--- a/dev-python/six/six-1.16.0-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} python3_13t pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python 2 and 3 compatibility library"
-HOMEPAGE="
- https://github.com/benjaminp/six/
- https://pypi.org/project/six/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-
-distutils_enable_sphinx documentation --no-autodoc
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # requires USE=gdb on CPython, no point in forcing the dep
- # also missing on PyPy
- 'test_six.py::test_move_items[dbm_ndbm]'
- )
-
- case ${EPYTHON} in
- python3.13*)
- EPYTEST_DESELECT+=(
- 'test_six.py::test_move_items[tkinter_tix]'
- )
- ;;
- esac
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}