summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-20 22:27:52 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-20 22:43:47 +0100
commit7c3bd4d10aef624a40fe8bb4dbaadc8e3b9fa30b (patch)
tree53080f0bbb78b11554a3804d5d49e0ea3b1aee40 /dev-python/snappy
parentdev-util/rebar: version bump to 2.6.3 (diff)
downloadgentoo-7c3bd4d10aef624a40fe8bb4dbaadc8e3b9fa30b.tar.gz
gentoo-7c3bd4d10aef624a40fe8bb4dbaadc8e3b9fa30b.tar.bz2
gentoo-7c3bd4d10aef624a40fe8bb4dbaadc8e3b9fa30b.zip
dev-python/snappy: add py3.5, EAPI=6, fix deps
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3569
Diffstat (limited to 'dev-python/snappy')
-rw-r--r--dev-python/snappy/metadata.xml15
-rw-r--r--dev-python/snappy/snappy-0.5-r3.ebuild32
2 files changed, 40 insertions, 7 deletions
diff --git a/dev-python/snappy/metadata.xml b/dev-python/snappy/metadata.xml
index 24add7c04bb2..0c0b8793dd9c 100644
--- a/dev-python/snappy/metadata.xml
+++ b/dev-python/snappy/metadata.xml
@@ -1,11 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">python-snappy</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-snappy</remote-id>
+ <remote-id type="github">andrix/python-snappy</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/snappy/snappy-0.5-r3.ebuild b/dev-python/snappy/snappy-0.5-r3.ebuild
new file mode 100644
index 000000000000..a246a795d728
--- /dev/null
+++ b/dev-python/snappy/snappy-0.5-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN=python-${PN}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python library for the snappy compression library from Google"
+HOMEPAGE="https://pypi.python.org/pypi/python-snappy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+
+RDEPEND=">=app-arch/snappy-1.0.2"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}
+"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ "${EPYTHON}" test_snappy.py -v || die "Tests fail with ${EPYTHON}"
+}