summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 08:03:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 08:30:36 +0200
commit12353ed0710620586d511ed8b533ba3965bac67b (patch)
tree29ba49bce076e8cc486bee3d44137d197f238c8a /dev-python/sphinxcontrib-serializinghtml
parentdev-python/pysimdjson: Add python@ as co-maint. (diff)
downloadgentoo-12353ed0710620586d511ed8b533ba3965bac67b.tar.gz
gentoo-12353ed0710620586d511ed8b533ba3965bac67b.tar.bz2
gentoo-12353ed0710620586d511ed8b533ba3965bac67b.zip
dev-python/sphinxcontrib-serializinghtml: Bump to 1.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-serializinghtml')
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/Manifest1
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.5.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-serializinghtml/Manifest b/dev-python/sphinxcontrib-serializinghtml/Manifest
index eb7aea8bb8ec..762c453ed69b 100644
--- a/dev-python/sphinxcontrib-serializinghtml/Manifest
+++ b/dev-python/sphinxcontrib-serializinghtml/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-serializinghtml-1.1.4.tar.gz 18647 BLAKE2B aa5dcbacf28a0433cbe86d9da3f6dc5859ec6148f74714654f5095ed1f21042e0d4ab1cbfb1bc816c1de40136ac51cb6f78c913cebf5465a4a11c25b22b36a14 SHA512 d132f75f1e0491167cd6d0f5b3697ac0fc1b16e63fd3dcd480b961e332b521932e405679a695522a4aeb56f57949eb9b1ed7635e9807dd059ae44a6384bdc6d0
+DIST sphinxcontrib-serializinghtml-1.1.5.tar.gz 21019 BLAKE2B e2da8b1e1300a327b8d508ce98e7c0d3eff1e0cea28cd874df4fbd9ed0bd4de6c17e107e622ec72e00bb237025ae26b2c5aaa33b2156cee2fad7c8f8d2c65ed5 SHA512 c5aabe4d29fd0455c269f8054089fdd61e1de5c35aa407740fc3baae4cfb3235d9fd5515c0489b0becd12abc8f18d0f42aa169ed315c00f30ba87e64ce851667
diff --git a/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.5.ebuild b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.5.ebuild
new file mode 100644
index 000000000000..1ad6f58cf77c
--- /dev/null
+++ b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs outputs serialized HTML files"
+HOMEPAGE="https://www.sphinx-doc.org
+ https://github.com/sphinx-doc/sphinxcontrib-serializinghtml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${PDEPEND} )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}