summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-07-28 22:06:54 +0300
committerMichał Górny <mgorny@gentoo.org>2023-07-29 04:45:10 +0200
commit56fc725cc5471a9ce37b3077fc8b525aa88a5ffe (patch)
tree7150075b25f0172b3b59a7fefba57437528fee21 /dev-python/sqlglot
parentsys-devel/kgcc64: add 13.2.0 (diff)
downloadgentoo-56fc725cc5471a9ce37b3077fc8b525aa88a5ffe.tar.gz
gentoo-56fc725cc5471a9ce37b3077fc8b525aa88a5ffe.tar.bz2
gentoo-56fc725cc5471a9ce37b3077fc8b525aa88a5ffe.zip
dev-python/sqlglot: add 17.8.6
Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/32085 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-17.8.6.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index e3b05d47c347..b7dcfdb891a7 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -1 +1,2 @@
DIST sqlglot-17.8.4.tar.gz 8373260 BLAKE2B e3b67c940eb608a25705fd280c0165ad7f37db1fcda2f6bc55029af2ad673a789901fbb2e6af72b54d15b75bc84827afadb00cc965efdc3323587278a68f6cf5 SHA512 c1717e7e857ddb9ff700c739b76cd3714e57ae0f7b620593b4fdce53cbf8e37d39882fac1308c3277a236f695292ae1c15541e474d28bdd43d889c2756b172df
+DIST sqlglot-17.8.6.tar.gz 8382262 BLAKE2B 70c14c50cbd673122e0560d41b26076ff2d22c75d611cb751ae3df9e5f98e8392440144edcb38bde272f5a95ac85a48cb85358a75dd9b53a1b72e8133964c15c SHA512 839d10ef3d589dd258a5297dc21846e0aafd145892e4c2650aa12ea16064da1dceacd9e1f9cbd6f804b8590435db61066cb01a92b3a1d88a69b1aa8dffaeb15b
diff --git a/dev-python/sqlglot/sqlglot-17.8.6.ebuild b/dev-python/sqlglot/sqlglot-17.8.6.ebuild
new file mode 100644
index 000000000000..d44b4e19523f
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-17.8.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/dateutil
+}