summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-27 17:44:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-27 17:59:46 +0200
commit3867b8d3ae0da2f6644639a4cff007a6ea67f2dd (patch)
tree005789338973cded3a7ac43c31749be13204089e /dev-python/starlette
parentdev-python/pyzotero: Bump to 1.5.10 (diff)
downloadgentoo-3867b8d3ae0da2f6644639a4cff007a6ea67f2dd.tar.gz
gentoo-3867b8d3ae0da2f6644639a4cff007a6ea67f2dd.tar.bz2
gentoo-3867b8d3ae0da2f6644639a4cff007a6ea67f2dd.zip
dev-python/starlette: Bump to 0.31.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/starlette')
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.31.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index f085a39de099..cfdc752c1bda 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1 +1,2 @@
DIST starlette-0.30.0.gh.tar.gz 2844387 BLAKE2B 00457d4913bd1c99fc6972baae56c5ebe84ba8215c6dd4f7875f6d93856ba40454d8a72828e715624bb945dce4abfbe407ed16e289a393af7be980f36389f9ae SHA512 751077fcfe3d344584d8986f3fc2bc25208716ca215db8ce62dfc752008dacd95f4834367f0921ceacaafa6b20409a9912f49ceabc23d7e9e5f636c6fb3646b2
+DIST starlette-0.31.1.gh.tar.gz 2846196 BLAKE2B 08ebe13d4b9716c6ff74a4f9ca6333f5e6dc31c6ce359b39cbf8e9822fad2e8c8a111788a37893ad687f4d3ffb3bef1e21146f3769b3ac07f083b1c454c07fa3 SHA512 8501b1f40fea9351eba8366dfe1adcb27d19a64a2f547153f3106f8d6828a47c850d6ffb634d6ce60e74fc02d510afda22bca33e07631b72f9a5558e977ea0f6
diff --git a/dev-python/starlette/starlette-0.31.1.ebuild b/dev-python/starlette/starlette-0.31.1.ebuild
new file mode 100644
index 000000000000..5157f33105ee
--- /dev/null
+++ b/dev-python/starlette/starlette-0.31.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/python-multipart[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest