summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-02-27 09:56:43 +0000
committerMarek Szuba <marecki@gentoo.org>2023-02-27 10:01:04 +0000
commit32c66d8a84bbf34e0dbaa4e0da8b05421a30005c (patch)
treed55a7bc83d0322b5eb5a516bb60b4c128cafe7a1 /dev-python/stomp-py
parentdev-python/pytest-verbose-parametrize: enable py3.11 (diff)
downloadgentoo-32c66d8a84bbf34e0dbaa4e0da8b05421a30005c.tar.gz
gentoo-32c66d8a84bbf34e0dbaa4e0da8b05421a30005c.tar.bz2
gentoo-32c66d8a84bbf34e0dbaa4e0da8b05421a30005c.zip
dev-python/stomp-py: add 8.1.0
Closes: https://bugs.gentoo.org/896894 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/stomp-py')
-rw-r--r--dev-python/stomp-py/Manifest1
-rw-r--r--dev-python/stomp-py/stomp-py-8.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/stomp-py/Manifest b/dev-python/stomp-py/Manifest
index 110bda934ae0..e102c44a5334 100644
--- a/dev-python/stomp-py/Manifest
+++ b/dev-python/stomp-py/Manifest
@@ -1 +1,2 @@
DIST stomp.py-8.0.1.tar.gz 35300 BLAKE2B 12209e99066fb5bb1f3015398f5eb27186322ce9d92feca46adc4d275aff1d5138908da69abe3be512325bd30a3a21773886ba5fa21917c71d13bc53b0977de4 SHA512 009189cd07c379641c9fa3b3af1df70c9e26b77bbb6d2443a78b56ff9895b4382e90a753db83f4a863fae5ef5765c660d2f82ef14ab6e74817bc83e7ea8ba6d3
+DIST stomp.py-8.1.0.tar.gz 39808 BLAKE2B c6efb19fbee81142f251c4bf4114b445878b81fa457260a306cb82ef5e9c57f0b75e3dc8cd6035676e688f1d33081cdf936ac6ccc0628819722849d60f4d8602 SHA512 7385842a23fbe6022c386489641948932e805430ce71c09079d9484fe17d02241ee705d92a1bcdf873eebcbacf68f44bbf884ea103c8963944b84758073fdac7
diff --git a/dev-python/stomp-py/stomp-py-8.1.0.ebuild b/dev-python/stomp-py/stomp-py-8.1.0.ebuild
new file mode 100644
index 000000000000..2aaf49e80681
--- /dev/null
+++ b/dev-python/stomp-py/stomp-py-8.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client library for the STOMP messaging protocol"
+HOMEPAGE="https://pypi.org/project/stomp.py/ https://github.com/jasonrbriggs/stomp.py/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="<dev-python/docopt-0.7.0[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_P}
+
+# stomp.py test suite requires quite a few appropriately configured
+# messaging servers (as of 7.0.0: RabbitMQ, ActiveMQ, ActiveMQ Artemis,
+# stompserver). Upstream relies on Docker to provide those servers, however
+# doing the same in src_test would require both granting the portage user
+# extra permissions and packaging the base image (trying to download it
+# on the fly would violate the network sandbox).
+# Side note: PyPI tarballs do not include tests.
+RESTRICT="test"