summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <mthode@mthode.org>2015-09-01 10:58:25 -0500
committerMatthew Thode <mthode@mthode.org>2015-09-01 11:07:59 -0500
commitb196019106fd08957f8bf84c86d15e0271cedbfd (patch)
tree4ed9bf2b1d3739d399b5dd6b1a2d1c105c8caa2a /dev-python/tempest-lib
parentdev-python/os-testr: adding for liberty (diff)
downloadgentoo-b196019106fd08957f8bf84c86d15e0271cedbfd.tar.gz
gentoo-b196019106fd08957f8bf84c86d15e0271cedbfd.tar.bz2
gentoo-b196019106fd08957f8bf84c86d15e0271cedbfd.zip
dev-python/tempest-lib: bup for liberty
Diffstat (limited to 'dev-python/tempest-lib')
-rw-r--r--dev-python/tempest-lib/Manifest1
-rw-r--r--dev-python/tempest-lib/tempest-lib-0.7.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/tempest-lib/Manifest b/dev-python/tempest-lib/Manifest
index 8217374defd1..95d57cfb2bae 100644
--- a/dev-python/tempest-lib/Manifest
+++ b/dev-python/tempest-lib/Manifest
@@ -1,3 +1,4 @@
DIST tempest-lib-0.3.0.tar.gz 53341 SHA256 0b2fdfe904b6bea12f5572f03307623ad43256694c17a5bd92ee837d8698d3c5 SHA512 e03617bd5e19b5872e4ae1e60c0eef2dfe325646f0b9d1c518f668bd7d054866b79aed494820f6ca99ee3d0735cc807aae7942f5f343e4d6c663368197be0f2c WHIRLPOOL 5f06bbaeeeb95b4724878481ddb500e1f7eaca98110cbcd2fe768917ed986656e64fae2e78e97cb099b776dbe069ad50f5c7717927ee78a5bf54f4638e8c9eec
DIST tempest-lib-0.4.0.tar.gz 68776 SHA256 b1d00f9da6d14b5ffac87710efd9d533361b8af11003728ee3b47591358f17b0 SHA512 f0f959de4f003971929c015a5a020921f9338805d9f1109e8d42ec9b5eb43702858182c5eaf43bc1b1c4006a01f96243ec6aad9fa9b93823f04b499ad09f5c81 WHIRLPOOL 01b147dd7f5929407c1d01dc8ad10ae2cbd6c0f2f08e628689025cb649dec9446d881245ab81d1370a7ff93c4ab0d5b9fb4c7ac0837b5ba3ad0c8b7b90bf46a8
DIST tempest-lib-0.5.0.tar.gz 74579 SHA256 696c6ccbbe13236096a94176ba2970e44853962c5ab93186286316696f384b29 SHA512 3408cabec205c6c1b830a20a8e96333b69afeeaad35d5342aae8c13e01b5df177958fe2050eb24a37d572a495411f04675e9d9727f6ae34aed22093c9621cde4 WHIRLPOOL 1b8f138bd45a168e2c203ff31de19ddc0aecda8d377925223798d01de3a0ff16f55fb874b1297b7a80178ae4f8948528a0e58b8d2388d464b8afd56b30d8991c
+DIST tempest-lib-0.7.0.tar.gz 60274 SHA256 bfad226eafb390c51851289b93444a7661416491fe8bedb3bc23d372583e0087 SHA512 887cdc5d95b25d6b566009b145cbe871e298abdde38eac76d8a28a61433ddd153b0ceadd322d49fb1242250b1876a45966c7c572280863d3dc4f3460c1904a2f WHIRLPOOL 6cf1c32d099cc56540bbeebebd027131251f189f49ecb632850095192cf11c429cf67493b9f16e1a187ba23888fd2a75b5386d022518af9260e37f9a23450872
diff --git a/dev-python/tempest-lib/tempest-lib-0.7.0.ebuild b/dev-python/tempest-lib/tempest-lib-0.7.0.ebuild
new file mode 100644
index 000000000000..c872149392e3
--- /dev/null
+++ b/dev-python/tempest-lib/tempest-lib-0.7.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to assist in creating functional or integrated test suites for OpenStack projects."
+HOMEPAGE="https://pypi.python.org/pypi/tempest-lib https://github.com/openstack/tempest-lib"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/os-testr-0.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( ${RDEPEND}
+ >=dev-python/hacking-0.10[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.11[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/ddt-0.7.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests tempest_lib/tests || die "Tests fail with ${EPYTHON}"
+}