summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-python/tempora
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tempora')
-rw-r--r--dev-python/tempora/tempora-1.12.ebuild1
-rw-r--r--dev-python/tempora/tempora-1.14.1.ebuild1
-rw-r--r--dev-python/tempora/tempora-1.14.ebuild1
-rw-r--r--dev-python/tempora/tempora-1.7.ebuild1
4 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/tempora/tempora-1.12.ebuild b/dev-python/tempora/tempora-1.12.ebuild
index e7ee70bd0ac6..83ee056710a7 100644
--- a/dev-python/tempora/tempora-1.12.ebuild
+++ b/dev-python/tempora/tempora-1.12.ebuild
@@ -16,6 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~sparc ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
diff --git a/dev-python/tempora/tempora-1.14.1.ebuild b/dev-python/tempora/tempora-1.14.1.ebuild
index 7dc141194dc0..2914a9aa1bbb 100644
--- a/dev-python/tempora/tempora-1.14.1.ebuild
+++ b/dev-python/tempora/tempora-1.14.1.ebuild
@@ -16,6 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
diff --git a/dev-python/tempora/tempora-1.14.ebuild b/dev-python/tempora/tempora-1.14.ebuild
index 252b06eaaa3b..ca308edec773 100644
--- a/dev-python/tempora/tempora-1.14.ebuild
+++ b/dev-python/tempora/tempora-1.14.ebuild
@@ -16,6 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
diff --git a/dev-python/tempora/tempora-1.7.ebuild b/dev-python/tempora/tempora-1.7.ebuild
index 114fcdbcbafe..64281dd389f3 100644
--- a/dev-python/tempora/tempora-1.7.ebuild
+++ b/dev-python/tempora/tempora-1.7.ebuild
@@ -16,6 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]