summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-26 03:35:55 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-26 03:53:03 +0200
commitc0ae5806bce7323a10219107123a65e8901deeca (patch)
tree572ad350dafebfee697145d33e677acd324535b0 /dev-python/tempora
parentdev-python/google-api-python-client: Bump to 2.138.0 (diff)
downloadgentoo-c0ae5806bce7323a10219107123a65e8901deeca.tar.gz
gentoo-c0ae5806bce7323a10219107123a65e8901deeca.tar.bz2
gentoo-c0ae5806bce7323a10219107123a65e8901deeca.zip
dev-python/tempora: Bump to 5.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tempora')
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/tempora-5.7.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index 0a0f4cebaef7..168b78c6af03 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1 +1,2 @@
DIST tempora-5.6.0.tar.gz 21659 BLAKE2B 865fc851d852e054b389cbc5731a9523297b134c6d6e812cff9a6dfda8be0c0c9b2aa5f63324642ef3c151529f82292d867d01bf68a9aaa4f7a3e6d296a8f4bd SHA512 dd8dfe94813a482a2493e3129c9dd4f40dd399bc933a5348454b903d49def1c84a417696c24b66533bcfa93d3d334c67114bdc0cc2512ce39384c039911b4d0d
+DIST tempora-5.7.0.tar.gz 22239 BLAKE2B 11c9ba681b1973b75e22cc4a2c8bcc1a2620e0284ce1b7d42fda25ce8c2a35bd4a9a4b329013143dbfd27613a327fb8d3d048d1230f679a240ed5ea6abc9761a SHA512 4c1bc7e45cfa1f415bfa6bcee3d6b82246477279b89328a98b8b944dddf7184a515e0733bb868321f63cbcb21fcb7847543a2643c059e6d2e0721c2e66ad4239
diff --git a/dev-python/tempora/tempora-5.7.0.ebuild b/dev-python/tempora/tempora-5.7.0.ebuild
new file mode 100644
index 000000000000..1ee7ce022944
--- /dev/null
+++ b/dev-python/tempora/tempora-5.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="
+ https://github.com/jaraco/tempora/
+ https://pypi.org/project/tempora/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-freezer[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p freezer
+}