summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-22 14:11:34 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-22 14:15:38 +0200
commit25f0debe2efd9a9c540201fe95def0c670f3a89e (patch)
tree3871397cd5b135ae132fcd063507b0d4006a04a5 /dev-python/termcolor
parentdev-python/tenacity: Bump to 8.1.0 (diff)
downloadgentoo-25f0debe2efd9a9c540201fe95def0c670f3a89e.tar.gz
gentoo-25f0debe2efd9a9c540201fe95def0c670f3a89e.tar.bz2
gentoo-25f0debe2efd9a9c540201fe95def0c670f3a89e.zip
dev-python/termcolor: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/termcolor')
-rw-r--r--dev-python/termcolor/Manifest1
-rw-r--r--dev-python/termcolor/termcolor-2.0.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/termcolor/Manifest b/dev-python/termcolor/Manifest
index 954e1615bdbb..9b8c6b6de279 100644
--- a/dev-python/termcolor/Manifest
+++ b/dev-python/termcolor/Manifest
@@ -1,2 +1,3 @@
DIST termcolor-1.1.0.tar.gz 3912 BLAKE2B 8d661a708eff02894b6e390befddaef1c9d14f78f0c7d10ac332fa149f7892109f77bd279c9a488a3aa4070569c92f0ce847e3911d419ff549a10555b34534fb SHA512 4bd06bf4405a9ef6c005cd4d159ef602f7fc7fccb3e57586da1187c402f4d0b9051ef930cae423065c51ff4be8a22ceae556a61a6b3c8c519d623c066c340b53
DIST termcolor-2.0.0.tar.gz 9701 BLAKE2B 3c1d81b21788c07870724ca162828037eee11b2c472fbe4cf9c60583155a0eb665c59bbab824882038f453d539b2c3c8518b51e373deb9755205b41b517d8ed3 SHA512 3b5f937c94ba3c0eac04073851fa53123262b3de4e081635069ebd2115b51cf37f88bf129f19d356886487cbeda381921022e52b560b7cbc8a9d935bc902dc6e
+DIST termcolor-2.0.1.tar.gz 9693 BLAKE2B 68592597da70957bd3f03a9a76e546ab17f7c437d00aca53325a617b02c5600679c9912c0ca8d9f7ade03a042cd657e86b1e12a588ec1eeafdfa57f3f5f16372 SHA512 e49f05e587fb420aa373d1644d66e4832a701385fc1da85470fa0d811770f73908ca139e1c1e9cb968cbc74285b038833f371854edc6e20bc22059b31ef1a1ed
diff --git a/dev-python/termcolor/termcolor-2.0.1.ebuild b/dev-python/termcolor/termcolor-2.0.1.ebuild
new file mode 100644
index 000000000000..61b84954a4c0
--- /dev/null
+++ b/dev-python/termcolor/termcolor-2.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI Color formatting for output in terminal"
+HOMEPAGE="
+ https://github.com/termcolor/termcolor/
+ https://pypi.org/project/termcolor/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest