summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-03-03 21:34:31 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-03 22:00:32 +0100
commite5875eb89db237a9477f457973ee256a065f840e (patch)
tree15364ef3be5b873caeff342da0645ff6eb227521 /dev-python/theano
parentdev-python/theano-pymc: Add blocker against dev-python/theano (diff)
downloadgentoo-e5875eb89db237a9477f457973ee256a065f840e.tar.gz
gentoo-e5875eb89db237a9477f457973ee256a065f840e.tar.bz2
gentoo-e5875eb89db237a9477f457973ee256a065f840e.zip
dev-python/theano: Remove colliding bin/__init__.py file
Bug: https://bugs.gentoo.org/774072 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/19755 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/theano')
-rw-r--r--dev-python/theano/theano-1.0.5-r1.ebuild (renamed from dev-python/theano/theano-1.0.5.ebuild)8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/theano/theano-1.0.5.ebuild b/dev-python/theano/theano-1.0.5-r1.ebuild
index bf10d34c41e1..aa340176494e 100644
--- a/dev-python/theano/theano-1.0.5.ebuild
+++ b/dev-python/theano/theano-1.0.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -42,6 +42,12 @@ python_test() {
nosetests --verbosity=3 -e test_format_flake8 || die
}
+# https://dev.gentoo.org/~mgorny/python-guide/concept.html#packaging-pkgutil-style-namespaces-in-gentoo
+python_install() {
+ rm "${BUILD_DIR}"/lib/bin/__init__.py || die
+ distutils-r1_python_install
+}
+
pkg_postinst() {
optfeature "Make picture of Theano computation graph" dev-python/pydot-ng
optfeature "Required for GPU/CPU code generation" dev-python/pygpu