summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-11 07:18:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-11 07:51:52 +0200
commit3da1a35f02e60662c2c8db5de38843d702f79f3f (patch)
treeae915d37a1e75598fc48fc68f7a5b5ef0b289989 /dev-python/time-machine
parentdev-python/pyfakefs: Bump to 5.2.3 (diff)
downloadgentoo-3da1a35f02e60662c2c8db5de38843d702f79f3f.tar.gz
gentoo-3da1a35f02e60662c2c8db5de38843d702f79f3f.tar.bz2
gentoo-3da1a35f02e60662c2c8db5de38843d702f79f3f.zip
dev-python/time-machine: Bump to 2.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/time-machine')
-rw-r--r--dev-python/time-machine/Manifest1
-rw-r--r--dev-python/time-machine/time-machine-2.11.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/time-machine/Manifest b/dev-python/time-machine/Manifest
index 94f6241d2342..17a7be6d693b 100644
--- a/dev-python/time-machine/Manifest
+++ b/dev-python/time-machine/Manifest
@@ -1,2 +1,3 @@
DIST time-machine-2.10.0.gh.tar.gz 28770 BLAKE2B ba4ff7dd2559530e86e38d23600209f2e860a1541c9ef5536d07092678018c210ec5e0c63bc615e81b62e8179324953d023ba247c501aa94e16beb0345cacf8f SHA512 4a3120432cb6aacb1e022415094a4fb204d2f1b39c378307a0de34505d470982d81e1d2d940d0b9745c3edcd563ff55f9ab1d602bd1dea720a474fee5fa1e4af
+DIST time-machine-2.11.0.gh.tar.gz 28075 BLAKE2B 2eb07ac60d4014e5796fefcf5cb846d60fef1887fe01459d906a2118eddc924d60642131530f76e131080e2989f60263bda2fbcc0cc917e0f9452d16a4f640a6 SHA512 5bd5d76e2ecc392c249e86e2cfe54ee94a99a4e1cd1dd7e00b240e1299426d87a284ec270ae36aeb82acfe06d974d5aeca27ae977a480441e4daa5b852d00198
DIST time-machine-2.9.0.gh.tar.gz 28043 BLAKE2B 9a9a521c94b72a7464853661da791b6f57f5155ddc62ffceeb82f808903f4c337e6bf48fe8300bb4f9f5673fd175fd85038a4e80a39e8f3e096c12c27ee790ec SHA512 ecc780a72d279b49d026a8f3f89210cb4c90e02c5a517c08eadbabcb65216a24c603ace39afd76ea1e6ccdef589d5997581d0db7477bb28fe4d1e0510daf17a0
diff --git a/dev-python/time-machine/time-machine-2.11.0.ebuild b/dev-python/time-machine/time-machine-2.11.0.ebuild
new file mode 100644
index 000000000000..d6f96f71fc73
--- /dev/null
+++ b/dev-python/time-machine/time-machine-2.11.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Travel through time in your tests"
+HOMEPAGE="
+ https://github.com/adamchainz/time-machine/
+ https://pypi.org/project/time-machine/
+"
+SRC_URI="
+ https://github.com/adamchainz/time-machine/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest