summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-17 05:10:06 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-17 05:33:22 +0200
commitd9d03c2794865cb4f8169d1a5ea22e5bee7f0409 (patch)
tree0dd278a4ef399a7f612429c9dbbca3dd35a9af8b /dev-python/tldextract
parentinstall-qa-check.d: Fix 60python-pyc to test pypy3.* as well (diff)
downloadgentoo-d9d03c2794865cb4f8169d1a5ea22e5bee7f0409.tar.gz
gentoo-d9d03c2794865cb4f8169d1a5ea22e5bee7f0409.tar.bz2
gentoo-d9d03c2794865cb4f8169d1a5ea22e5bee7f0409.zip
dev-python/tldextract: Bump to 3.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tldextract')
-rw-r--r--dev-python/tldextract/Manifest1
-rw-r--r--dev-python/tldextract/tldextract-3.4.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/tldextract/Manifest b/dev-python/tldextract/Manifest
index ef943c08079c..9997eed81671 100644
--- a/dev-python/tldextract/Manifest
+++ b/dev-python/tldextract/Manifest
@@ -1,2 +1,3 @@
DIST tldextract-3.4.0.tar.gz 111437 BLAKE2B 94a3a77144fcaddebdf2129cea8fd43e971f0ac9b40029c6c1735ee06f499f4bf48823fc61540d99f71fd62192742c10168ef8f25b534eec9e2a04d3879be63a SHA512 6cd6b079c35af62e4f8da67c687630471d1a57ebfab7d982abe411b03fb6673dd238a1f676de5624d13bd2eb42b91ae0a97708e33579217916d88bca4db218db
DIST tldextract-3.4.1.tar.gz 104202 BLAKE2B 24e6f5a4af1718fdf3b52b2c12146849033b80fc0ba0320ccf72735fd0e39c36678660a70a203964ebd92acb3911e037b899b1796a941731735fa1e028999cd1 SHA512 6b63ba8f800e1adc836ecee43947fc0ee5198eefe7d3f64a267c7e0a4d18a44c60454ba67636a4b19e00a125f8b37f1f816f782976a9a335e5500a333c8e07aa
+DIST tldextract-3.4.2.tar.gz 105004 BLAKE2B 0bf2eddea49983720a554874bf1ec2d3280317657c9752d87ef825c9ce451f15a443c847d2bdbd6ac0f3fa3166da4bfce9852f6aff6710c5a53d8ac42541e9f2 SHA512 60ec9d99339940354db03e01d46bed571d604be9edce406476696d6a4d5e07677243f4c7f40fb1ca7e7f2f6bbe9d7d25a4959ade7f5091bcf89524c2c9cc927d
diff --git a/dev-python/tldextract/tldextract-3.4.2.ebuild b/dev-python/tldextract/tldextract-3.4.2.ebuild
new file mode 100644
index 000000000000..421d0afe56cf
--- /dev/null
+++ b/dev-python/tldextract/tldextract-3.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Accurately separate the TLD from the registered domain and subdomains of a URL"
+HOMEPAGE="
+ https://github.com/john-kurkowski/tldextract/
+ https://pypi.org/project/tldextract/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-file[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest