summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-10 04:36:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-10 04:53:04 +0200
commit5b479655af7b9cd144f2f13559a894919b62503b (patch)
treec94e3c4ac1258f8a51a5b3ce64ba62280a86f882 /dev-python/tqdm
parentdev-python/cerberus: Bump to 1.3.5 (diff)
downloadgentoo-5b479655af7b9cd144f2f13559a894919b62503b.tar.gz
gentoo-5b479655af7b9cd144f2f13559a894919b62503b.tar.bz2
gentoo-5b479655af7b9cd144f2f13559a894919b62503b.zip
dev-python/tqdm: Bump to 4.66.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.66.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 385bf4c5073a..e5a10fb70762 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,2 +1,3 @@
DIST tqdm-4.65.0.tar.gz 167542 BLAKE2B b1f7b5666600dd5c476ffc9852cdc8905b8819b6b3f812e00495fa38780dda0c59e48956881d46919ce57b13da9dde519fa7e22d91ed58fe43172da8e9043653 SHA512 86315b57d8ceec69ee8970b25372b26b03d2d37f6d06e037e712bf16c7f56eac1c4049291e451c7df62273b91ba7149b400efd0186ceee90268d854e7b476c47
DIST tqdm-4.65.2.tar.gz 167099 BLAKE2B 5b3d1444aacd3ffa46149889ed5eee3bc851da2c000fcfbd06ceda811ad6df3fd7f9b5da90e7124930ebfd8249a52d194d807d7f8e8b1170966d2b1e6128fc7b SHA512 012810c5844f4034388469a4ce71382067a42960a534e2720d412483b3668040367e94c1865dcd44855cf1f2c7e28312b6084d579348492d7ca3ba5241395f40
+DIST tqdm-4.66.0.tar.gz 169029 BLAKE2B 1b8277174a62ac01ef61b21822aa87bc933db2b7ac8ed134ba41920daac7e75fdc6bbd8596fde7b54de377c4900f5f2dde8126548dde055feac327da38bfc152 SHA512 23c871f61d45caa5ceee4cf191e063f91123d69c641111857023432cdceaa1ddfb957fea1b6390801cd9cd9fa9a42b4adc29854340f28cc9a2400295b3f18065
diff --git a/dev-python/tqdm/tqdm-4.66.0.ebuild b/dev-python/tqdm/tqdm-4.66.0.ebuild
new file mode 100644
index 000000000000..0472066fc4d2
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.66.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="
+ https://github.com/tqdm/tqdm/
+ https://pypi.org/project/tqdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Skip unpredictable performance tests
+ tests/tests_perf.py
+)
+
+python_install_all() {
+ doman tqdm/tqdm.1
+ newbashcomp tqdm/completion.sh tqdm
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}