summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/turbolift
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/turbolift')
-rw-r--r--dev-python/turbolift/Manifest1
-rw-r--r--dev-python/turbolift/metadata.xml16
-rw-r--r--dev-python/turbolift/turbolift-2.0.5.ebuild36
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/turbolift/Manifest b/dev-python/turbolift/Manifest
new file mode 100644
index 000000000000..186a25695379
--- /dev/null
+++ b/dev-python/turbolift/Manifest
@@ -0,0 +1 @@
+DIST turbolift-2.0.5.tar.gz 47316 SHA256 7ea374122855949481427201327f08198a5b164c59057e7f07f9812b9d0c5e0d SHA512 42b89d4dc1a4699bc4d43863f0d9faeb5cd1442222a7d93a008a8d335bee25112e16c2e0a05d05442e53a5e4e4f7a7012b420bd49d8d0e5668fe1b487b825834 WHIRLPOOL 9199fbdc62d15bd18227cc5deb84870f01ef8569be1f491292aa5c5c6b54afbdc5eedbae23a8eeb02f8bf92ca2694ec649417ea61f13a0fc2762a0790d24b90b
diff --git a/dev-python/turbolift/metadata.xml b/dev-python/turbolift/metadata.xml
new file mode 100644
index 000000000000..a809de117fa1
--- /dev/null
+++ b/dev-python/turbolift/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Openstack Swift sync/backup utility
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">turbolift</remote-id>
+ <remote-id type="github">cloudnull/turbolift</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/turbolift/turbolift-2.0.5.ebuild b/dev-python/turbolift/turbolift-2.0.5.ebuild
new file mode 100644
index 000000000000..97f8c3fa9812
--- /dev/null
+++ b/dev-python/turbolift/turbolift-2.0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+# tests are not distributed with the release tarball
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Openstack Swift sync/backup utility"
+HOMEPAGE="https://github.com/cloudnull/turbolift/wiki"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools
+ test? (
+ >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND=">=dev-python/prettytable-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} -m unit discover turbolift/tests || die "failed testsuite"
+}