summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-17 18:50:53 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-17 20:43:34 +0100
commitfd74d153a753f17b9d8e6b328a663b282326bfb1 (patch)
tree4e5bff3569dd17ef44bcf83fb890665537709e3c /dev-python/tweepy/tweepy-3.3.0.ebuild
parentdev-python/httreplay: New package, ebuild written by me (diff)
downloadgentoo-fd74d153a753f17b9d8e6b328a663b282326bfb1.tar.gz
gentoo-fd74d153a753f17b9d8e6b328a663b282326bfb1.tar.bz2
gentoo-fd74d153a753f17b9d8e6b328a663b282326bfb1.zip
dev-python/tweepy: Fix tests
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/tweepy/tweepy-3.3.0.ebuild')
-rw-r--r--dev-python/tweepy/tweepy-3.3.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/tweepy/tweepy-3.3.0.ebuild b/dev-python/tweepy/tweepy-3.3.0.ebuild
index 16cbb91c967a..263fad6e34b6 100644
--- a/dev-python/tweepy/tweepy-3.3.0.ebuild
+++ b/dev-python/tweepy/tweepy-3.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -22,6 +22,7 @@ RESTRICT="test" #missing in tarball
DEPEND="
dev-python/pip[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
"
RDEPEND="
>=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
@@ -37,7 +38,7 @@ python_prepare_all() {
}
python_test() {
- "${PYTHON}" -m tests || die "Tests failed"
+ nosetests -v -c tests/travis-tests.cfg || die
}
python_compile_all() {