summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-04 06:00:57 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-04 06:00:57 +0100
commit23cdb6b2d0dbd6565740fbc01ef700289de8e199 (patch)
treedc63813616fe85c845082fb852aab7882a4d2cdf /dev-python/typed-ast
parentapp-admin/awscli: Bump to 1.22.20 (diff)
downloadgentoo-23cdb6b2d0dbd6565740fbc01ef700289de8e199.tar.gz
gentoo-23cdb6b2d0dbd6565740fbc01ef700289de8e199.tar.bz2
gentoo-23cdb6b2d0dbd6565740fbc01ef700289de8e199.zip
dev-python/typed-ast: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typed-ast')
-rw-r--r--dev-python/typed-ast/Manifest1
-rw-r--r--dev-python/typed-ast/typed-ast-1.5.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/typed-ast/Manifest b/dev-python/typed-ast/Manifest
index 12650b008bc9..d21aa5d5e06d 100644
--- a/dev-python/typed-ast/Manifest
+++ b/dev-python/typed-ast/Manifest
@@ -1 +1,2 @@
DIST typed_ast-1.4.3.tar.gz 210893 BLAKE2B 9e0bbaac73d97c13303c783d4e91b015570d9b9ad74361e1bcfe67259982459003ea6c24602ce004fe1447c4375090d5fa58006e18af28da256f6b25d9aa20b1 SHA512 7ac06e277c883afd1a7161601ffca0114aa63db257695a4bf4c64d819a7192fe52167edb57991aefc7accc6a9902b5faf2ba9e4032c4b9be31f1db7a091607c9
+DIST typed_ast-1.5.1.tar.gz 252316 BLAKE2B 4bb2987cc84277a595c8297563f257e495a4b298885f54b82ce177f5ce610809f462d0022a549e83c4c991e441720f36bd2451eef3487fc68ceda76b845a01d2 SHA512 9e1b1e5da242f29c52857a5a683be47d95b592c788a7c603fc38f637ee64f687253aa58994061681c703addd2405532dfdc0765dd1cadf16b339623901f61355
diff --git a/dev-python/typed-ast/typed-ast-1.5.1.ebuild b/dev-python/typed-ast/typed-ast-1.5.1.ebuild
new file mode 100644
index 000000000000..93028922127a
--- /dev/null
+++ b/dev-python/typed-ast/typed-ast-1.5.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python typed-ast backported"
+HOMEPAGE="https://pypi.org/project/typed-ast/ https://github.com/python/typed_ast"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+S="${WORKDIR}/${P/-/_}"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ epytest
+}