summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-18 06:48:12 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-18 06:48:12 +0200
commit743d4f2a2444fda46383359ee2c60e576a2823f8 (patch)
tree8db18bb103d260b54edb867267584c2168a41752 /dev-python/typeguard
parentapp-admin/awscli: Bump to 1.29.29 (diff)
downloadgentoo-743d4f2a2444fda46383359ee2c60e576a2823f8.tar.gz
gentoo-743d4f2a2444fda46383359ee2c60e576a2823f8.tar.bz2
gentoo-743d4f2a2444fda46383359ee2c60e576a2823f8.zip
dev-python/typeguard: Bump to 4.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/Manifest1
-rw-r--r--dev-python/typeguard/typeguard-4.1.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index 6587109cda3f..80f59f1cd94d 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -2,3 +2,4 @@ DIST typeguard-4.0.0.tar.gz 66064 BLAKE2B 250ef359fedb83df7573c9acb97f80fbf1d5b9
DIST typeguard-4.0.1.tar.gz 67242 BLAKE2B bf0b092402e4044675f1252a1ad4657fa8ec316bfda5e0afcce609f616e8d86998c059544ebbeea73eb5fa627eeae9371d46581b33891319f7b2385faa359310 SHA512 2e93086309550d6b98f2087a8900797ab9486c1a969da649d1a6cb508f6154b57b6807762e87df43088f80b69bcc11f87c71d83b38ca205d3ad8878a2cd4eb0e
DIST typeguard-4.1.0.tar.gz 67584 BLAKE2B d2f6777cad306410d4a536312a981600371e0e0cae224eee286e3b6bd48a0777ca587eb44b4f48fd9a2c7fe5e35d274f5d1c2eb508ed9708b25b686b395976fb SHA512 5a1a374c1b9679cf1d840a750698caea47deae0fcec8eda3312773fd8eee8ccc533030b78c8e1c8bfae6bee79c323ba421176b2c8d2e85a87444ba767891ede7
DIST typeguard-4.1.1.tar.gz 67711 BLAKE2B e4fd162d858907afea9e4bbaed7960fb3e8728acfa921cf889ba53422d21a09e5a0811b942aa7db564cc247d43ea3dca12f9124ae4ae54e3e4d6804dc443c35a SHA512 93a9f7ae5eabee85b133024971019647b6f49eff12059fdcfbf76927585362734c9db6e9c42dcbd97d63d498fd06d240f882fe8cd08a854c2214241e3a2bd1b2
+DIST typeguard-4.1.2.tar.gz 67758 BLAKE2B 89d9502ac3d3685ca7b3dcbf0725a4a758fa3dff97a69eb64447e61e27629a5aa2cf4bd8fddfe8d552a383487329c22818030100a20642a71eed21780018d778 SHA512 4fc45a725d1aaaab01fa0f88711965d7d859111857df6f4e480daa73119d3c8da3f987ddec39c22ede74fbb7fe1278f4a62fdc468aa1699d19ae700af0317760
diff --git a/dev-python/typeguard/typeguard-4.1.2.ebuild b/dev-python/typeguard/typeguard-4.1.2.ebuild
new file mode 100644
index 000000000000..2d5d1842fcbf
--- /dev/null
+++ b/dev-python/typeguard/typeguard-4.1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.7.0[${PYTHON_USEDEP}]
+ ' 3.{10..11})
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # mypy changes results from version to version
+ tests/mypy
+ )
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # the XFAIL test pass due to some package being installed
+ epytest -o xfail_strict=False
+}