summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-27 20:24:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-27 20:24:38 +0200
commit4fb2e25eb3fec9f91048c6509e5caa8f7de5bd22 (patch)
tree34ba6334b923f8e5410870cabfb5eb549d2fcf1d /dev-python/vecrec
parentdev-python/terminaltables: Enable py3.12 (diff)
downloadgentoo-4fb2e25eb3fec9f91048c6509e5caa8f7de5bd22.tar.gz
gentoo-4fb2e25eb3fec9f91048c6509e5caa8f7de5bd22.tar.bz2
gentoo-4fb2e25eb3fec9f91048c6509e5caa8f7de5bd22.zip
dev-python/vecrec: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/vecrec')
-rw-r--r--dev-python/vecrec/vecrec-0.3.1-r1.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/vecrec/vecrec-0.3.1-r1.ebuild b/dev-python/vecrec/vecrec-0.3.1-r1.ebuild
index d47d6a69f6e7..595c6bd2e9fc 100644
--- a/dev-python/vecrec/vecrec-0.3.1-r1.ebuild
+++ b/dev-python/vecrec/vecrec-0.3.1-r1.ebuild
@@ -4,29 +4,32 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="2D vector and rectangle classes"
-HOMEPAGE="https://github.com/kxgames/vecrec
- https://pypi.org/project/vecrec/"
+HOMEPAGE="
+ https://github.com/kxgames/vecrec/
+ https://pypi.org/project/vecrec/
+"
LICENSE="MIT"
KEYWORDS="~amd64"
SLOT="0"
-RDEPEND="dev-python/autoprop[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/autoprop[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest
src_prepare() {
- sed -e '/addopts/d' -i tests/pytest.ini || die
sed -e '/build-backend/s/flit.buildapi/flit_core.buildapi/' \
-e '/requires/s/flit/flit_core/' -i pyproject.toml || die
distutils-r1_src_prepare
}
python_test() {
- epytest tests
+ epytest -o addopts= tests
}