summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-10-08 13:10:44 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-21 23:38:35 +0200
commite7508e278b17c9982c4c9b928895be1910308f1d (patch)
treebebd7a97fad8c36303e28967e94a2f0a4b1fcf8b /dev-python/vobject/vobject-0.9.3.ebuild
parentdev-python/python-levenshtein: python3_5, EAPI 6 (diff)
downloadgentoo-e7508e278b17c9982c4c9b928895be1910308f1d.tar.gz
gentoo-e7508e278b17c9982c4c9b928895be1910308f1d.tar.bz2
gentoo-e7508e278b17c9982c4c9b928895be1910308f1d.zip
dev-python/vobject: 0.9.3 bump, python3, EAPI 6, fix HOMEPAGE, DESCRIPTION
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2513 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/vobject/vobject-0.9.3.ebuild')
-rw-r--r--dev-python/vobject/vobject-0.9.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/vobject/vobject-0.9.3.ebuild b/dev-python/vobject/vobject-0.9.3.ebuild
new file mode 100644
index 000000000000..90f112695929
--- /dev/null
+++ b/dev-python/vobject/vobject-0.9.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package for parsing and generating vCard and vCalendar files"
+HOMEPAGE="http://eventable.github.io/vobject/
+ https://pypi.python.org/pypi/vobject
+ https://github.com/eventable/vobject"
+SRC_URI="https://github.com/eventable/vobject/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools"[${PYTHON_USEDEP}]
+DEPEND="${RDEPEND}"
+
+DOCS=( ACKNOWLEDGEMENTS.txt README.md )
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Testing failed under ${EPYTHON}"
+}