summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-06 07:34:02 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-06 07:34:02 +0100
commit9c6934893b9e54272dc0694376686c9e856c85b1 (patch)
treeafb66d82bf92c729b7ec5ff3008b150790ba036c /dev-python/wcwidth
parentdev-python/markdown-exec: Bump to 1.8.0 (diff)
downloadgentoo-9c6934893b9e54272dc0694376686c9e856c85b1.tar.gz
gentoo-9c6934893b9e54272dc0694376686c9e856c85b1.tar.bz2
gentoo-9c6934893b9e54272dc0694376686c9e856c85b1.zip
dev-python/wcwidth: Bump to 0.2.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wcwidth')
-rw-r--r--dev-python/wcwidth/Manifest1
-rw-r--r--dev-python/wcwidth/wcwidth-0.2.13.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/wcwidth/Manifest b/dev-python/wcwidth/Manifest
index ef5606b1a903..28c94b93de80 100644
--- a/dev-python/wcwidth/Manifest
+++ b/dev-python/wcwidth/Manifest
@@ -1 +1,2 @@
DIST wcwidth-0.2.12.tar.gz 99898 BLAKE2B 3bfec1c2ab34103bf0706fcd0385dd034e2381f47b355a71c1167647c5fc168fa1b84737d0aae04412dceedc8417b6982455a826d1114f6f948e8755a9727838 SHA512 3d8d9d2c750f2e97db42135dc1322fc432ce25edc8e692b263e5b80c96779398e8b8eecdc7305f7d974b8dbc037f6c6ec8b5af343763660c841759f40e2249be
+DIST wcwidth-0.2.13.tar.gz 101301 BLAKE2B 33637e5582cff1bbc0f11c044d390dc18b635af923c7c89c79c07f20bafb44434ad79801b19d89c9e15b8bee79b52f5652ea3987e5578520aedfbb03f20fd6cb SHA512 1eadda149936cf2eefe5d09c411774dc87c8a358f2dd92d74f427d7b47f07c05557e849c46122d44788c2bd7c97eb85fc5f902d9a158d68ab9e352c5185ba2d5
diff --git a/dev-python/wcwidth/wcwidth-0.2.13.ebuild b/dev-python/wcwidth/wcwidth-0.2.13.ebuild
new file mode 100644
index 000000000000..236793d8ec68
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.2.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="
+ https://pypi.org/project/wcwidth/
+ https://github.com/jquast/wcwidth/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}
+
+python_install_all() {
+ docinto docs
+ dodoc docs/intro.rst
+ distutils-r1_python_install_all
+}