summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-09 05:41:41 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-09 07:26:42 +0200
commiteaaaaa2e8748c25abf2bf5edcd92fc8acff63833 (patch)
tree6226113188e6fb346a7a8ca19829a3da1e015bb7 /dev-python/werkzeug
parentdev-python/mkdocs-material: Bump to 9.1.11 (diff)
downloadgentoo-eaaaaa2e8748c25abf2bf5edcd92fc8acff63833.tar.gz
gentoo-eaaaaa2e8748c25abf2bf5edcd92fc8acff63833.tar.bz2
gentoo-eaaaaa2e8748c25abf2bf5edcd92fc8acff63833.zip
dev-python/werkzeug: Bump to 2.3.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-2.3.4.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index dc9acfb8fd0a..84ca83183b74 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -3,3 +3,4 @@ DIST werkzeug-2.3.0.gh.tar.gz 831666 BLAKE2B 2d4c792deab6e153794695e249ca97f24b5
DIST werkzeug-2.3.1.gh.tar.gz 832058 BLAKE2B d92836c168339e4dfb07c27d8379548a6805e9aec884cb41b76b9b4196f982ec6d05a6e505bb2ad70e591e54a4a2cecd683b5b6b78a058f90adab704da154d1f SHA512 02b5feb1e4d5c7b24d7b890c579cd3211eb430101d14800ca6c1e2a244da90fee4d5c0cd4819ead58a2885df0c736c796720fd9a3378a1eabaf417aefaa5a919
DIST werkzeug-2.3.2.gh.tar.gz 832353 BLAKE2B 61806869549e356f244eb808823813473e5d7e00b7b085720f02429d3c2f30ceffb0bf7daeb57f0ef0b94fe836c8d895bc8a4b0b2d284536297718f4f0912b64 SHA512 03b866cc7b2d539ade9284632e55dd66598a06596f3ef1de2b3af9081d8b3c6745eb94744faf7f93abe383615efb3453a41544975fbfb548582ca1912ad932dc
DIST werkzeug-2.3.3.gh.tar.gz 832625 BLAKE2B 66a243af0b0158722184ef098280b1556a43c99c4266d9d0c28898474a36a2ac63096444994e792add7119b17ac94fd2b145055495a1ffbdf84983dfd0cc6928 SHA512 969dfc7412378ba9373f6fb3bee4129f4bbd3a502e7f320fedb29464005b1e2ee9afc9241128ef06271592a978d229ae2633cbaf8ae9e2161f4c099a09715adc
+DIST werkzeug-2.3.4.gh.tar.gz 833090 BLAKE2B e9d0134fa2a1355a2ef0df0f86cca6ea0f0a0c9b6ece98a6774ceab0a284c6a899e915688cb3e2e9f6192a7943cbcf20578d1e8f2f439dd8a9ab0f3d49361bcd SHA512 1e519fc88ac4438aa4dbd623ef8afc96a630df61d25a5a28154749f5c38593edefbb32163a632a5f38fa70d8cf2f1ae93633e54cfafe72d497ab70c99f9b2478
diff --git a/dev-python/werkzeug/werkzeug-2.3.4.ebuild b/dev-python/werkzeug/werkzeug-2.3.4.ebuild
new file mode 100644
index 000000000000..5b00c8084bee
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-2.3.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://palletsprojects.com/p/werkzeug/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/
+"
+SRC_URI="
+ https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+"
+# NOTE: remove the loong mask after greenlet gains support for loong
+# see https://github.com/python-greenlet/greenlet/pull/257
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.3[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ !hppa? ( !ia64? ( !loong? (
+ $(python_gen_cond_dep '
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ ' 'python3*')
+ ) ) )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ epytest -p no:django -p no:httpbin tests
+}