summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-13 08:26:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-13 08:32:20 +0200
commitdb91414409cd414f291510642a6a318156fe5efe (patch)
tree0dfccdb1885bf8ddde30df9d99fd1d9b1483f5cf /dev-python/wheel
parentapp-editors/neovim: Fix cmake unused variable warning (diff)
downloadgentoo-db91414409cd414f291510642a6a318156fe5efe.tar.gz
gentoo-db91414409cd414f291510642a6a318156fe5efe.tar.bz2
gentoo-db91414409cd414f291510642a6a318156fe5efe.zip
dev-python/wheel: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/Manifest1
-rw-r--r--dev-python/wheel/wheel-0.38.4.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
index 3e16760be045..e8a990def985 100644
--- a/dev-python/wheel/Manifest
+++ b/dev-python/wheel/Manifest
@@ -1,2 +1 @@
-DIST wheel-0.38.4.gh.tar.gz 69770 BLAKE2B a6077e38c21626169d68a3256fbe6457de3d4fde5d0a582859fe7b9ec5d73c142538f7fbfe762ddd436473c682e7810407a08730f66ec2a7844084d349e0779f SHA512 2ff7c6175201f8145f2c1f9937c6955a1dd22eeedab1e456f65c4edae9186610d9e7702c35773b49026c56c9cc201672025e7d42fcc7f782153c65c28e6b90d0
DIST wheel-0.40.0.tar.gz 96226 BLAKE2B f4207ab822f037a3d8decc50643ad7e49a632028c712bc33c680d178f10117ff0aa4f2a971bf739a77a76dbf818360d0f628ce997b942ee9d85ec7fac28badc8 SHA512 211e68d927c93b9b2748bf081097d1172cf8d4863d540be72f1d6023b64042410805d4208a2c94de89a1eeb0fb32044e78f41ab58ac94498ac0c489a1eea0d23
diff --git a/dev-python/wheel/wheel-0.38.4.ebuild b/dev-python/wheel/wheel-0.38.4.ebuild
deleted file mode 100644
index 25f92e0cf74c..000000000000
--- a/dev-python/wheel/wheel-0.38.4.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A built-package format for Python"
-HOMEPAGE="
- https://github.com/pypa/wheel/
- https://pypi.org/project/wheel/
-"
-SRC_URI="
- https://github.com/pypa/wheel/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos ~x64-solaris"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unbundle packaging
- rm -r src/wheel/vendored || die
- sed -i -e 's:\.vendored\.::' src/wheel/*.py || die
- sed -i -e 's:wheel\.vendored\.::' tests/*.py || die
-
- distutils-r1_src_prepare
-}
-
-src_configure() {
- [[ -e pyproject.toml ]] &&
- die "Upstream added pyproject.toml, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "wheel"
- description = "A built-package format for Python"
- dynamic = ["version"]
-
- [project.scripts]
- wheel = "wheel.cli:main"
-
- [project.entry-points."distutils.commands"]
- bdist_wheel = "wheel.bdist_wheel:bdist_wheel"
- EOF
-}