summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-27 09:24:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-27 09:28:29 +0200
commit284c58a9b7fcede6ddab8e40f30c2e0155193b77 (patch)
tree8d06614c8d252daa7a7292a086856505f7cd604f /dev-python/wsgiproxy2
parentdev-python/importlib_metadata: Bump to 4.7.1 (diff)
downloadgentoo-284c58a9b7fcede6ddab8e40f30c2e0155193b77.tar.gz
gentoo-284c58a9b7fcede6ddab8e40f30c2e0155193b77.tar.bz2
gentoo-284c58a9b7fcede6ddab8e40f30c2e0155193b77.zip
dev-python/wsgiproxy2: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wsgiproxy2')
-rw-r--r--dev-python/wsgiproxy2/Manifest1
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.5.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/wsgiproxy2/Manifest b/dev-python/wsgiproxy2/Manifest
index db5ec8b30340..2e92aa18fae9 100644
--- a/dev-python/wsgiproxy2/Manifest
+++ b/dev-python/wsgiproxy2/Manifest
@@ -1,2 +1,3 @@
DIST WSGIProxy2-0.4.6.tar.gz 16481 BLAKE2B c33dc34d430da795e8144e06e1d6f100cce7d0155295c2d3038567a048647a4f008dbc0156fd4234ce069b3f4ec01af0e42b174dd68c92c9cb3ff4e13be83f8a SHA512 c60d794c0c8b383bf1857ec325d6d0b4fce9c4aec4a06cbf9d7549b609633e491e137342b7bbaf4eec12462eabba63096328c8517b0685e241d1baecd5827cad
DIST WSGIProxy2-0.5.0.tar.gz 16464 BLAKE2B be8f818a1eb3280598427d52b4a7661f5c3cb86a4701e6c3c6b9c57bfde740a0ed616f9f6df8d7f4539c6716898bb5f7ebbf245d72452d84da9862df7cbec761 SHA512 8351225ffe78069f35e636efbd508d3ccd1a3365ac8846bc8fd5712c04869d21c1f9e9e9207d286649713cb9dcbc4770cf41f2c5f06a8d72e86f290211f05c0a
+DIST WSGIProxy2-0.5.1.tar.gz 16565 BLAKE2B 54bdc404111d910af61a59a7da5d47924e1950162dfb79dc0fd221a417c4fbb717dc4e7cf521589e3d087ffce1917449a199f5278bd4410ccce391b9c551eced SHA512 6be9d4893515cc70ee1c5d7b7a29895a8c8b5afd316e2ad05f92fc1fa93e26da22b93440994ec9782f0663ff7073e476f75351fb7955bde93a2b6fbf9f4bf78a
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.5.1.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.5.1.ebuild
new file mode 100644
index 000000000000..d76f3faa2193
--- /dev/null
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_PN="WSGIProxy2"
+DESCRIPTION="HTTP proxying tools for WSGI apps"
+HOMEPAGE="https://pypi.org/project/WSGIProxy2/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest