summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-10 17:28:41 +0100
committerSam James <sam@gentoo.org>2023-09-10 17:28:46 +0100
commit3270eeb0bb5f0834dc54da4f20b2e9d856510cb2 (patch)
tree3306f1092ea9b76b4c997bad48bf936ae95bdda1 /dev-python/wxpython
parentdev-python/pygobject: Version bump to 3.46.0 (diff)
downloadgentoo-3270eeb0bb5f0834dc54da4f20b2e9d856510cb2.tar.gz
gentoo-3270eeb0bb5f0834dc54da4f20b2e9d856510cb2.tar.bz2
gentoo-3270eeb0bb5f0834dc54da4f20b2e9d856510cb2.zip
dev-python/wxpython: fix build w/ cython-3
Closes: https://bugs.gentoo.org/911703 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/files/wxpython-4.2.0-cython-3.patch19
-rw-r--r--dev-python/wxpython/wxpython-4.2.0.ebuild1
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/wxpython/files/wxpython-4.2.0-cython-3.patch b/dev-python/wxpython/files/wxpython-4.2.0-cython-3.patch
new file mode 100644
index 000000000000..aff380108b8e
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-4.2.0-cython-3.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/911703
+https://github.com/wxWidgets/Phoenix/pull/2441
+
+From aeb557d01e7cd37176ebbf0f1ae6d0b53c115378 Mon Sep 17 00:00:00 2001
+From: Scott Talbert <swt@techie.net>
+Date: Tue, 25 Jul 2023 12:42:32 -0400
+Subject: [PATCH] Fix compatibility with Cython 3.0.0
+
+Remove unused import which seems to be removed in Cython 3.
+--- a/wx/svg/_nanosvg.pyx
++++ b/wx/svg/_nanosvg.pyx
+@@ -42,7 +42,6 @@ for manipulating the SVG shape info in memory.
+
+ import sys
+
+-cimport cython.object
+ from cpython.buffer cimport (
+ Py_buffer, PyObject_CheckBuffer, PyObject_GetBuffer, PyBUF_SIMPLE,
+ PyBuffer_Release)
diff --git a/dev-python/wxpython/wxpython-4.2.0.ebuild b/dev-python/wxpython/wxpython-4.2.0.ebuild
index d5528c5f28f0..5d44d61b86f0 100644
--- a/dev-python/wxpython/wxpython-4.2.0.ebuild
+++ b/dev-python/wxpython/wxpython-4.2.0.ebuild
@@ -51,6 +51,7 @@ PATCHES=(
#"${FILESDIR}/${PN}-4.0.6-skip-broken-tests.patch"
"${FILESDIR}/${PN}-4.2.0-no-attrdict.patch"
"${FILESDIR}/${PN}-4.2.0-flags.patch"
+ "${FILESDIR}/${PN}-4.2.0-cython-3.patch"
)
python_prepare_all() {