summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-03 23:24:14 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-04 17:47:44 +0200
commit7a3405e55ceea5ea8480c93639f7b51c7d491ca9 (patch)
tree22970424f3da821117c0bfb85576a2ac7a18a3a6 /dev-python/youtube-search-python
parentdev-python/simber: new package; add version 0.2.4 (diff)
downloadgentoo-7a3405e55ceea5ea8480c93639f7b51c7d491ca9.tar.gz
gentoo-7a3405e55ceea5ea8480c93639f7b51c7d491ca9.tar.bz2
gentoo-7a3405e55ceea5ea8480c93639f7b51c7d491ca9.zip
dev-python/youtube-search-python: new package; add version 1.6.3
Bug: https://github.com/deepjyoti30/ytmdl/issues/222 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python/youtube-search-python')
-rw-r--r--dev-python/youtube-search-python/Manifest1
-rw-r--r--dev-python/youtube-search-python/metadata.xml13
-rw-r--r--dev-python/youtube-search-python/youtube-search-python-1.6.3.ebuild22
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/youtube-search-python/Manifest b/dev-python/youtube-search-python/Manifest
new file mode 100644
index 000000000000..1a181d73d22b
--- /dev/null
+++ b/dev-python/youtube-search-python/Manifest
@@ -0,0 +1 @@
+DIST youtube-search-python-1.6.3.tar.gz 115934 BLAKE2B 1151a29da0d66206424a88a2ac3839269f11d970b4a829f9d33ede4ef7ffec39c6762bfe138edd5da9c57308444021be93054c34cbc71e12a031a8d798d94975 SHA512 16d0dfbc95387bb3ccac9224e53ea087cdfa41d1330abd96fc3ad0136af227359fc2d8409a2eca81ae2fe9790efdb86a42e409748ba1a49c595df2629216e331
diff --git a/dev-python/youtube-search-python/metadata.xml b/dev-python/youtube-search-python/metadata.xml
new file mode 100644
index 000000000000..bc129c31ebbe
--- /dev/null
+++ b/dev-python/youtube-search-python/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/alexmercerind/youtube-search-python/issues/</bugs-to>
+ <remote-id type="github">alexmercerind/youtube-search-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/youtube-search-python/youtube-search-python-1.6.3.ebuild b/dev-python/youtube-search-python/youtube-search-python-1.6.3.ebuild
new file mode 100644
index 000000000000..923cfa88f17f
--- /dev/null
+++ b/dev-python/youtube-search-python/youtube-search-python-1.6.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get YouTube video information using link WITHOUT YouTube Data API v3"
+HOMEPAGE="https://github.com/alexmercerind/youtube-search-python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+ net-misc/yt-dlp[${PYTHON_USEDEP}]
+"