summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <z@pyl.onl>2024-07-21 11:09:57 -0500
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-21 19:42:31 +0200
commit5ba10768a27097f46441ced75090a9201df687a6 (patch)
tree6591868e0bfee072d5c7f3d6dfd5f358257e8a9e /dev-python/zenlib
parentapp-i18n/librime: refactor after PR (diff)
downloadgentoo-5ba10768a27097f46441ced75090a9201df687a6.tar.gz
gentoo-5ba10768a27097f46441ced75090a9201df687a6.tar.bz2
gentoo-5ba10768a27097f46441ced75090a9201df687a6.zip
dev-python/zenlib: Add 2.2.0, 9999
Signed-off-by: Zen <z@pyl.onl> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/zenlib')
-rw-r--r--dev-python/zenlib/Manifest1
-rw-r--r--dev-python/zenlib/zenlib-2.2.0.ebuild16
-rw-r--r--dev-python/zenlib/zenlib-9999.ebuild15
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/zenlib/Manifest b/dev-python/zenlib/Manifest
index e41725b9cd43..026eb6c288e7 100644
--- a/dev-python/zenlib/Manifest
+++ b/dev-python/zenlib/Manifest
@@ -1 +1,2 @@
DIST zenlib-2.1.2.tar.gz 17293 BLAKE2B 3d5067b9796f31d28d0ca04c842b4ef1807e0557a77c5b6ec5798cfa2aa04ee5e7eafa3549df6add4228e7c3014ca33eb1584c0aee6db9c0acc882f170972b36 SHA512 a0a53ed63a3efe83dc8f49fd512685b82ed383494f404072a47734c02a1955e0a4c9a6c9df48503419c82cb7479783669b6de8deef174a597ab73cad61da5c3e
+DIST zenlib-2.2.0.tar.gz 17727 BLAKE2B 073bbaa252ab000a30602e0a603a8293b8c3a322374ad4172758a6c95d52483b03cc84d4b72aa868168bde03796defb3efca85682ca8f7b7fce6243d8112198f SHA512 4b324e1b56d757536a80d4d5fe31d4087ee8e1a0aa1ff8a19a43252033ea6e5115c55c5c6d69bcae8594bc36c84625b75df2ce93a2f49f7b885179aa05b45d80
diff --git a/dev-python/zenlib/zenlib-2.2.0.ebuild b/dev-python/zenlib/zenlib-2.2.0.ebuild
new file mode 100644
index 000000000000..901021ca3bc9
--- /dev/null
+++ b/dev-python/zenlib/zenlib-2.2.0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1
+
+DESCRIPTION="Useful python decorators and utilities"
+HOMEPAGE="https://github.com/desultory/zenlib"
+SRC_URI="https://github.com/desultory/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
diff --git a/dev-python/zenlib/zenlib-9999.ebuild b/dev-python/zenlib/zenlib-9999.ebuild
new file mode 100644
index 000000000000..032dbf828303
--- /dev/null
+++ b/dev-python/zenlib/zenlib-9999.ebuild
@@ -0,0 +1,15 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Useful python decorators and utilities"
+HOMEPAGE="https://github.com/desultory/zenlib"
+EGIT_REPO_URI="https://github.com/desultory/zenlib.git"
+
+LICENSE="GPL-2"
+SLOT="0"