summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-30 07:40:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-30 09:20:34 +0200
commit12e80573e33b5a4ded36ccc14841f9afcac48731 (patch)
tree14f5d8aa6e0788d4c12c5c8dbb58587e5a45a887 /dev-python
parentdev-python/flit_scm: Bump to 1.6.2 (diff)
downloadgentoo-12e80573e33b5a4ded36ccc14841f9afcac48731.tar.gz
gentoo-12e80573e33b5a4ded36ccc14841f9afcac48731.tar.bz2
gentoo-12e80573e33b5a4ded36ccc14841f9afcac48731.zip
dev-python/marshmallow: Bump to 3.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.16.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index cab3ce6a18c2..8a91f74597f2 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
DIST marshmallow-3.15.0.tar.gz 179483 BLAKE2B 5cd660f4b1bf3ffb775e06659adce2f0da8bf46bd5376eb4407793925de60fce48ac633baced399314d9cef1faaf00f2643e56404cdc2c44e51b5b0c42ab533d SHA512 9d688466b9dfce7cd3307538aadb68c8297d3ee026a7a61953d361a9e52acafd00da81f48ab26771dba74bf8024117d53292763ab98cb78e2bbd7b5604bee4f1
+DIST marshmallow-3.16.0.tar.gz 180106 BLAKE2B c3d9b9c1645e7df103940b8e637f3de027f23e5da4a6ebd25412fef9d2d61483ec934af5c37f781121928a7b2f98b44793a8671173a5c548936ce0bbd0d2290d SHA512 5d3c7babff9117261afb902090bffcdba4eee2984d13862f4974fc043c6e56420707a6d3aba4a6046d947ef9414386c24895fc9a2538e36e505692e76d70f409
diff --git a/dev-python/marshmallow/marshmallow-3.16.0.ebuild b/dev-python/marshmallow/marshmallow-3.16.0.ebuild
new file mode 100644
index 000000000000..98fb29348702
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.16.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-0.17[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest