summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-08 21:16:06 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-08 21:16:06 +0200
commit133577996521d0dc652cd0fa41a642c085336a3f (patch)
tree0ff477d8852c32f4007ac10266c933df7f5394f0 /dev-python
parentmedia-gfx/gnofract4d: amd64 stable wrt bug #681508 (diff)
downloadgentoo-133577996521d0dc652cd0fa41a642c085336a3f.tar.gz
gentoo-133577996521d0dc652cd0fa41a642c085336a3f.tar.bz2
gentoo-133577996521d0dc652cd0fa41a642c085336a3f.zip
dev-python/tracing: [QA] Call distutils-r1_python_install_all
Closes: https://bugs.gentoo.org/682166 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tracing/tracing-0.10.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/dev-python/tracing/tracing-0.10.ebuild b/dev-python/tracing/tracing-0.10.ebuild
index c09ce44ba558..d6f70ff1f199 100644
--- a/dev-python/tracing/tracing-0.10.ebuild
+++ b/dev-python/tracing/tracing-0.10.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python2_7 )
@@ -16,16 +16,22 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="doc examples"
+DEPEND="doc? ( dev-python/sphinx )"
+
python_compile_all() {
- use doc && emake -C doc html
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/. )
+ rm -rf doc/_build/html/{objects.inv,_sources} || die
+ fi
}
python_install_all() {
- dodoc README
- use doc && dohtml -r doc/_build/html/
+ distutils-r1_python_install_all
+
if use examples; then
- docompress -x usr/share/doc/${PF}/examples/
- insinto usr/share/doc/${PF}/examples/
- doins example.py
+ docinto examples
+ dodoc example.py
+ docompress -x /usr/share/doc/${PF}/examples/
fi
}