summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-26 21:05:30 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-26 21:06:18 +0200
commit36d111cc81a02e81181ed7a4081aa165ec83fbb1 (patch)
tree70806d3a632e28deadb55c4f883a9ff029744a30 /dev-python
parentdev-python/black: Disable pytest plugins (diff)
downloadgentoo-36d111cc81a02e81181ed7a4081aa165ec83fbb1.tar.gz
gentoo-36d111cc81a02e81181ed7a4081aa165ec83fbb1.tar.bz2
gentoo-36d111cc81a02e81181ed7a4081aa165ec83fbb1.zip
dev-python/black: Use pytest-forked to workaround fd leaks
Use pytest-forked to workaround fd leaks in blackd that cause the test suite to fail and hang on systems with high nproc (i.e. our arm64 and sparc devboxes). Bug: https://github.com/psf/black/issues/4504 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/black/black-24.10.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/black/black-24.10.0.ebuild b/dev-python/black/black-24.10.0.ebuild
index 7972d233773c..daff56b55149 100644
--- a/dev-python/black/black-24.10.0.ebuild
+++ b/dev-python/black/black-24.10.0.ebuild
@@ -38,6 +38,7 @@ BDEPEND="
dev-python/aiohttp-cors[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
)
"
@@ -45,7 +46,9 @@ distutils_enable_tests pytest
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
+ # pytest-forked to workaround fd leakage in blackd
+ # https://github.com/psf/black/issues/4504
+ epytest -p pytest_forked --forked
}
pkg_postinst() {