summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-03-24 15:49:38 -0400
committerMike Gilbert <floppym@gentoo.org>2020-03-24 15:49:47 -0400
commit3a900f982c2aed49871dafc44aed502c324bfbb2 (patch)
tree5c454aeb782d1a2f3683594b2f36942e84bbdbdc /dev-python
parentapp-misc/solaar: fix metadata whitespace (diff)
downloadgentoo-3a900f982c2aed49871dafc44aed502c324bfbb2.tar.gz
gentoo-3a900f982c2aed49871dafc44aed502c324bfbb2.tar.bz2
gentoo-3a900f982c2aed49871dafc44aed502c324bfbb2.zip
dev-python/fudge: bump to 1.1.1
Package-Manager: Portage-2.3.92_p3, Repoman-2.3.20_p118 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fudge/Manifest1
-rw-r--r--dev-python/fudge/fudge-1.1.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/fudge/Manifest b/dev-python/fudge/Manifest
index 75a79fdecdca..bd7fb50006ff 100644
--- a/dev-python/fudge/Manifest
+++ b/dev-python/fudge/Manifest
@@ -1 +1,2 @@
DIST fudge-1.1.0.tar.gz 86418 BLAKE2B 3264b693bb8d4e8a0849c480b48ee79e4e99a88a819f94bfab9c098fd8ccef1171f3f0a8ca7632f29b2c22998d0847e53fcc613bbdf8ac4c1fe33aeae406997c SHA512 061d9303d28509d4e22eb2036d041359f872be85911dd85bb16e4d13bfc1cf27637f8206f215f4a37d63108ab2500d2af3f6a1a3e206fe461ead9163e0519417
+DIST fudge-1.1.1.tar.gz 87604 BLAKE2B 2660022089ab50139fd4a63aa212c0f53d04557571fa444cc2fd74dd556475c04d3563359c49f0252d811b93a3d4215dddca32c7db91b81682adae2a7fb7f772 SHA512 4a5043048aef1bc4c7806b7a13e138810295f882739f728115a60f2b0157716d85a7bed8a3641b76213b788c74fe586f57854f96bf7a745d6006ad6e67dca136
diff --git a/dev-python/fudge/fudge-1.1.1.ebuild b/dev-python/fudge/fudge-1.1.1.ebuild
new file mode 100644
index 000000000000..d07cb65e79e8
--- /dev/null
+++ b/dev-python/fudge/fudge-1.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Replace real objects with fakes (mocks, stubs, etc) while testing"
+HOMEPAGE="http://farmdev.com/projects/fudge/ https://pypi.org/project/fudge/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -w "${BUILD_DIR}"/lib \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}