summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-01 17:28:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-01 18:04:16 +0100
commit46fb316bf34ef42112569e3ceb59a3564ca4280f (patch)
tree59cb2607095b89dbab88d04b2a504e10d2cb0b0a /dev-python
parentdev-python/setuptools: Bump to 53.0.0 (diff)
downloadgentoo-46fb316bf34ef42112569e3ceb59a3564ca4280f.tar.gz
gentoo-46fb316bf34ef42112569e3ceb59a3564ca4280f.tar.bz2
gentoo-46fb316bf34ef42112569e3ceb59a3564ca4280f.zip
dev-python/django: Bump to 3.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django/Manifest2
-rw-r--r--dev-python/django/django-3.1.6.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/django/Manifest b/dev-python/django/Manifest
index 4475355a7561..5863a878b886 100644
--- a/dev-python/django/Manifest
+++ b/dev-python/django/Manifest
@@ -6,3 +6,5 @@ DIST Django-3.1.4.checksum.txt 2466 BLAKE2B 635ddd40b542890aef29f53df0fad172e484
DIST Django-3.1.4.tar.gz 9392125 BLAKE2B b583442de50c358e70a49b9ef557d43211e6faee17933a44012dbb9f0dac3ccbf0a91e01a2b8b798fff7ae05100199e9e9c94a81748b41ea13e49d12bb510617 SHA512 02cfaabb25e5f932dcbf659faba2f0afe298e4bee4f510f7adebfff181bdd13c3a0b08e8ce379bcc59326d904be8699db4ce31065d93566b93cad758365207f5
DIST Django-3.1.5.checksum.txt 2428 BLAKE2B 69347177b3c8c592a0b9df832c8f0abebdd4f1ff420f95f63310eb41d3614b241dc8f01b71abfec12faa006a8e69310d31cd68425f57ecf7a02948e83c65e0b3 SHA512 93d3e0de057518b60d9da2c1193ec59a8601f53b5d81a09fa4f6866336fbff85b81c01711eb07544fce30fe17e6dec89e5a5d6a66a929d451bca77cfe172bf19
DIST Django-3.1.5.tar.gz 9257571 BLAKE2B 0ec618753d922e64b2f0e75506843383568c0013a8f7528cf10e9ee49ffc7be8a3effda39c27497510728a16d276db5c620bab22b5a001a86cafdb4d4e2560ea SHA512 b8f0e034fcd282d6e4a9e42565da5d5f4750c900264bed10e72b8c1866370f75fd1bc856d22950e1d3ad03229c38559989a26ccc9f1252ea31d407410134a548
+DIST Django-3.1.6.checksum.txt 2547 BLAKE2B 509254e5d24cdddfb452d922554db12a16ee1c5840d61d17f57c7b209aa71e3b8c8279efec35508cafd059836601d85bca16a33c618b466c438fc323bcbab720 SHA512 d9dd2763285ae9da7cf24bff957ed2cc78ab088fa34ad45fe176bd869fb892a0e50d2b67fb6a0fcda08f85c68602a3b1f76c265e3776d762f2ee1f96f0dd116f
+DIST Django-3.1.6.tar.gz 9645871 BLAKE2B 96269d5977d422e62637a956ea8b1af7abc4647350aa4c913e986a7104843d2a4d6c6425deabe2358e819692a721caa18002448b780d4384493bf9078bfbabd1 SHA512 fe5baef4aee51cc84292d1f4d3681cff8170c1307aa172b86faa15771af2c3e0b4dbb24ae671ad8ed31c53ab38ed99c64b5deb69d77fc268d8a232f3463c3221
diff --git a/dev-python/django/django-3.1.6.ebuild b/dev-python/django/django-3.1.6.ebuild
new file mode 100644
index 000000000000..e6482b2c0bde
--- /dev/null
+++ b/dev-python/django/django-3.1.6.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+
+inherit bash-completion-r1 distutils-r1 optfeature verify-sig
+
+MY_P=${P^}
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
+SRC_URI="
+ https://media.djangoproject.com/releases/$(ver_cut 1-2)/${MY_P}.tar.gz
+ verify-sig? ( https://media.djangoproject.com/pgp/${MY_P}.checksum.txt )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+IUSE="doc sqlite test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/asgiref[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/tblib[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ )
+ verify-sig? ( >=app-crypt/openpgp-keys-django-20201201 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1-bashcomp.patch
+)
+
+distutils_enable_sphinx docs --no-autodoc
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/django.asc
+
+src_unpack() {
+ if use verify-sig; then
+ cd "${DISTDIR}" || die
+ verify-sig_verify_signed_checksums \
+ "${MY_P}.checksum.txt" sha256 "${MY_P}.tar.gz"
+ cd "${WORKDIR}" || die
+ fi
+
+ default
+}
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ PYTHONPATH=. "${EPYTHON}" tests/runtests.py --settings=test_sqlite -v2 ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}-admin
+ bashcomp_alias ${PN}-admin django-admin.py
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "Additional Backend support can be enabled via"
+ optfeature "MySQL backend support" dev-python/mysqlclient
+ optfeature "PostgreSQL backend support" dev-python/psycopg:2
+ elog
+ elog "Other features can be enhanced by"
+ optfeature "GEO Django" "sci-libs/gdal[geos]"
+ optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+ optfeature "ImageField Support" dev-python/pillow
+ optfeature "Password encryption" dev-python/bcrypt
+ optfeature "High-level abstractions for Django forms" dev-python/django-formtools
+}