summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-29 09:13:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-29 09:18:22 +0200
commit4a619c23464e01b280c0ffe3c4b1452a227b37b6 (patch)
tree2e932fbc582c8cc4dce809db3ef3369e1a65c992 /dev-python
parentdev-python/httpcore: Bump to 0.13.1 (diff)
downloadgentoo-4a619c23464e01b280c0ffe3c4b1452a227b37b6.tar.gz
gentoo-4a619c23464e01b280c0ffe3c4b1452a227b37b6.tar.bz2
gentoo-4a619c23464e01b280c0ffe3c4b1452a227b37b6.zip
dev-python/google-api-python-client: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.3.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index b4df4c79ac66..9ddbb81c64cc 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -3,3 +3,4 @@ DIST google-api-python-client-2.0.0.tar.gz 23121166 BLAKE2B 427160b34982438ef7b2
DIST google-api-python-client-2.0.2.tar.gz 23122914 BLAKE2B 0df0b44b2e86088069c5abc1916e733340ccfdb5be7629a2b5f1fcc8e5597183213d2ec149ef64a879bd50710ac804839b7d3be3d912ff6f132473dc6b4050f1 SHA512 9224a1f925ddeedfa0237372b4c5d1dbab913e07a8885398b955ff188decea68ebcde36fdc06394674e31d8ff4dee02aba0e13ebf8f599b1fc19854c21f9ce85
DIST google-api-python-client-2.1.0.tar.gz 23921001 BLAKE2B 8594d79a0eb71587c2d0d55c3d9bc1414f5ec057594324638947fb408182a58f04a8672bbbfeda95a262ff2888d93e3e103730f592caf4d884d392f8ed894824 SHA512 c76075920a3e56f3d64ada1973ade61bb3806afd63e5bd184074b4a3a16e143aa5662543127e98451a942c6b47e8f9f28002ef52b548fc8702ef703c0da33cf4
DIST google-api-python-client-2.2.0.tar.gz 24631108 BLAKE2B 377b87d30a0adb2bdbf983e9821e8be5db371e70572d79cafc1c4d231206461d50373b87aed5927cf5a485c3c1b21819db2719107cf58472551a7a0f858d8090 SHA512 9e921aa4b3868f85ecc3eb572d465c13851b1dfa0e84d11706821d5d02511cd4ae4fab4b9b55c606446d5753dccb973a99de888fbfa890aa1fcb6083fde976de
+DIST google-api-python-client-2.3.0.tar.gz 24912943 BLAKE2B 60233808f0f6243c37e8915791975e9aa10fa2d82e54c183582db9712dc36920d7d99f6caa67a25a96b1806ae9f96fd4f371010472b753f7a80d5e4fab49bd3e SHA512 11b9ba2f6417c017d47c9563460c38afdbfd01658e6c0f1812b1cdd1068b04bd37bb362e2ade4214fcc9a89d758f31bc977e281b093793a48641a2b7d926715e
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.3.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.3.0.ebuild
new file mode 100644
index 000000000000..6ac513eb6f88
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.13.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ local deselect=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ distutils_install_for_testing
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}