summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-01 09:59:57 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-01 10:38:02 +0100
commit5eb222cbb8c9b29eb31b8757598a5722a78369b6 (patch)
treec2cbdb49a8c4f0ee34b4419654198a4bae9a2439 /dev-python
parentsci-physics/lammps: remove USE=kokkos (diff)
downloadgentoo-5eb222cbb8c9b29eb31b8757598a5722a78369b6.tar.gz
gentoo-5eb222cbb8c9b29eb31b8757598a5722a78369b6.tar.bz2
gentoo-5eb222cbb8c9b29eb31b8757598a5722a78369b6.zip
dev-python/QtPy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/QtPy/Manifest2
-rw-r--r--dev-python/QtPy/QtPy-1.11.2.ebuild158
-rw-r--r--dev-python/QtPy/QtPy-1.11.3-r1.ebuild139
3 files changed, 0 insertions, 299 deletions
diff --git a/dev-python/QtPy/Manifest b/dev-python/QtPy/Manifest
index 6bb3ddeff649..dfd253d5f51f 100644
--- a/dev-python/QtPy/Manifest
+++ b/dev-python/QtPy/Manifest
@@ -1,4 +1,2 @@
-DIST QtPy-1.11.2.tar.gz 37098 BLAKE2B 8806cce798c4c2d885dd340d0d077567353cf0f3f1c2b284fd788c190b28b6133d052d31dea861e7d2497d0db88ba7ce8be83074360c61823f7a78dc01c015a5 SHA512 e49beb3180789a8080a19406b0e122bc9fc2192ac89b59f0956d7c65ac957779b192062956a97a7526f32724000df18abf32ddd6bda52f9cdf440ddc551887f8
-DIST QtPy-1.11.3.tar.gz 39637 BLAKE2B d1bfa0944dcebf5e408b9a061bcc6bab2fe172a70f0eadd36b229d2c9b40d74d8159c820608d3afd71a91085d5703af9b7045f359209730c53a9a83007159ce5 SHA512 461d858b05ff75f27017f6f0058f3e47643d5fe6c236e4307fa006735ad80e4c1fa487f1ab75edcfe881026541e302cdc3f8221c4ad7b97bce8c96b66db580bb
DIST QtPy-2.0.0.tar.gz 39628 BLAKE2B bc1b2cf975c3457cb026016854ec70e0aa3247c1234643dbf95681f655678e43ba0200b26e16a0b9eafd6fb373c1f876d9a54458ceb9b9b035ad463b7874db2c SHA512 95855c305da7f54850bcb6297a1f12ceda79eaf6d9b01771b1391d2d7b07b8f690e134cc2d52417bcc320395dce8c1f7f5c6ccadf2939db196e0ed5441215d5a
DIST QtPy-2.0.1.tar.gz 43047 BLAKE2B 66625852e75fbfcf0bf96e740754ca26b6d5226dd5450d0274cf6dc875cba18e5ed8e339c8c7ad084ffa9b135f19447e087b338690ec521205316c4f22f09197 SHA512 5d482b0a5bd2be67a0fabccf98a9dedf28ef328641c8c976e2274d4a5afb14b9fefce251e80496ed54425dcb3da24984c6c36308db0bfc810ea2142528ad88fd
diff --git a/dev-python/QtPy/QtPy-1.11.2.ebuild b/dev-python/QtPy/QtPy-1.11.2.ebuild
deleted file mode 100644
index 80a6b0988c86..000000000000
--- a/dev-python/QtPy/QtPy-1.11.2.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Abstraction layer on top of PyQt5 and PySide2 and additional custom QWidgets"
-HOMEPAGE="https://github.com/spyder-ide/qtpy/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-
-_IUSE_QT_MODULES="
- declarative designer gui help location multimedia network opengl
- positioning printsupport sensors serialport speech sql svg testlib
- webchannel webengine websockets widgets x11extras xml xmlpatterns
-"
-IUSE="+pyqt5 pyside2 ${_IUSE_QT_MODULES}"
-unset _IUSE_QT_MODULES
-
-# PySide2 does not support python3_10, nor is it likely that it will in the
-# future since upstream appears to be focussing on PySide6 for Qt6 instead
-# (which is compatible with python3_10). So if we want to use python3_10
-# we have to force disable pyside2.
-REQUIRED_USE="
- || ( pyqt5 pyside2 )
- python_targets_python3_10? ( pyqt5 !pyside2 )
-"
-
-# These flags are currently *not* common to both the PySide2 and PyQt5 ebuild
-# Disable them for now, please check periodically if this is still up to date.
-# bluetooth? ( pyqt5 )
-# dbus? ( pyqt5 )
-#
-# 3d? ( pyside2 )
-# charts? ( pyside2 )
-# concurrent? ( pyside2 )
-# datavis? ( pyside2 )
-# scxml? ( pyside2 )
-# script? ( pyside2 )
-# scripttools? ( pyside2 )
-
-# WARNING: the obvious solution of using || for PyQt5/pyside2 is not going
-# to work. The package only checks whether PyQt5/pyside2 is installed, it does
-# not verify whether they have the necessary modules (i.e. satisfy the USE dep).
-#
-# Webengine is a special case, because PyQt5 provides this in a separate package
-# while PySide2 ships it in the same package.
-#
-# declarative/qml/quick is a special case, because PyQt5 bundles the bindings
-# for qml and quick in one flag: declarative PySide2 does not.
-#
-# The PyQt5 ebuild currently enables xml support unconditionally, the flag is
-# added anyway with a (+) to make it future proof if the ebuild were to change
-# this behaviour in the future.
-#
-# The PySide2 ebuild currently enables opengl and serialport support
-# unconditionally, the flag is added anyway with a (+) to make it future proof
-# if the ebuild were to change this behaviour in the future.
-RDEPEND="
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[declarative?,designer?,gui?,help?,location?]
- dev-python/PyQt5[multimedia?,network?,opengl?,positioning?]
- dev-python/PyQt5[printsupport?,sensors?,serialport?,speech(-)?,sql?,svg?]
- dev-python/PyQt5[testlib?,webchannel?,websockets?,widgets?]
- dev-python/PyQt5[x11extras?,xml(+)?,xmlpatterns?]
- webengine? ( dev-python/PyQtWebEngine[${PYTHON_USEDEP}] )
- )
- pyside2? (
- $(python_gen_cond_dep '
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[designer?,gui?,help?,location?,multimedia?]
- dev-python/pyside2[network?,opengl(+)?,positioning?,printsupport?]
- dev-python/pyside2[sensors?,serialport(+)?,speech?,sql?,svg?]
- dev-python/pyside2[testlib?,webchannel?,webengine?,websockets?]
- dev-python/pyside2[widgets?,x11extras?,xml?,xmlpatterns?]
- declarative? ( dev-python/pyside2[qml,quick] )
- ' python3_{7..9} )
- )
-"
-
-# The QtPy testsuite skips tests for bindings that are not installed, so here we
-# ensure that everything is available and all tests are run. Note that not
-# all flags are available in PyQt5/PySide2, so some tests are still skipped.
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[bluetooth,dbus,declarative,designer,gui,help,location]
- dev-python/PyQt5[multimedia,network,opengl,positioning,printsupport]
- dev-python/PyQt5[sensors,serialport,speech(-),sql,svg,testlib,webchannel]
- dev-python/PyQt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- )
- pyside2? (
- $(python_gen_cond_dep '
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
- dev-python/pyside2[location,multimedia,network,opengl(+),positioning]
- dev-python/pyside2[printsupport,qml,quick,script,scripttools,scxml]
- dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
- dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
- dev-python/pyside2[xml,xmlpatterns]
- ' python3_{7..9} )
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- default
- # Disale Qt for Python implementations that are not selected
- if ! use pyqt5; then
- sed -i -e "s/from PyQt5.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- fi
- if ! use pyside2; then
- sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide2.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- fi
-
- # Disable outdated PyQt4 and PySide
- sed -i -e "s/from PyQt4.Qt import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PyQt4.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide.QtCore import/raise ImportError #/" qtpy/__init__.py || die
-}
-
-src_test() {
- virtx python_foreach_impl python_test
-}
-
-python_test() {
- if use pyqt5; then
- QT_API="pyqt5" epytest
- fi
- if use pyside2; then
- if [[ "${EPYTHON}" == "python3.10" ]]; then
- return
- else
- QT_API="pyside2" epytest
- fi
- fi
-}
-
-pkg_postinst() {
- if use pyqt5 && use pyside2; then
- ewarn "You have enabled both PyQt5 and PySide2, note that QtPy will default"
- ewarn "to PyQt5 unless the QT_API environment variable overrides this."
- fi
-}
diff --git a/dev-python/QtPy/QtPy-1.11.3-r1.ebuild b/dev-python/QtPy/QtPy-1.11.3-r1.ebuild
deleted file mode 100644
index 56716c7509d2..000000000000
--- a/dev-python/QtPy/QtPy-1.11.3-r1.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Abstraction layer on top of PyQt5 and PySide2 and additional custom QWidgets"
-HOMEPAGE="https://github.com/spyder-ide/qtpy/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-_IUSE_QT_MODULES="
- declarative designer gui help location multimedia network opengl
- positioning printsupport sensors serialport speech sql svg testlib
- webchannel webengine websockets widgets x11extras xml xmlpatterns
-"
-IUSE="+pyqt5 pyside2 ${_IUSE_QT_MODULES}"
-unset _IUSE_QT_MODULES
-
-REQUIRED_USE="|| ( pyqt5 pyside2 )"
-
-# These flags are currently *not* common to both the PySide2 and PyQt5 ebuild
-# Disable them for now, please check periodically if this is still up to date.
-# bluetooth? ( pyqt5 )
-# dbus? ( pyqt5 )
-#
-# 3d? ( pyside2 )
-# charts? ( pyside2 )
-# concurrent? ( pyside2 )
-# datavis? ( pyside2 )
-# scxml? ( pyside2 )
-# script? ( pyside2 )
-# scripttools? ( pyside2 )
-
-# WARNING: the obvious solution of using || for PyQt5/pyside2 is not going
-# to work. The package only checks whether PyQt5/pyside2 is installed, it does
-# not verify whether they have the necessary modules (i.e. satisfy the USE dep).
-#
-# Webengine is a special case, because PyQt5 provides this in a separate package
-# while PySide2 ships it in the same package.
-#
-# declarative/qml/quick is a special case, because PyQt5 bundles the bindings
-# for qml and quick in one flag: declarative PySide2 does not.
-#
-# The PyQt5 ebuild currently enables xml support unconditionally, the flag is
-# added anyway with a (+) to make it future proof if the ebuild were to change
-# this behaviour in the future.
-#
-# The PySide2 ebuild currently enables opengl and serialport support
-# unconditionally, the flag is added anyway with a (+) to make it future proof
-# if the ebuild were to change this behaviour in the future.
-RDEPEND="
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[declarative?,designer?,gui?,help?,location?]
- dev-python/PyQt5[multimedia?,network?,opengl?,positioning?]
- dev-python/PyQt5[printsupport?,sensors?,serialport?,speech(-)?,sql?,svg?]
- dev-python/PyQt5[testlib?,webchannel?,websockets?,widgets?]
- dev-python/PyQt5[x11extras?,xml(+)?,xmlpatterns?]
- webengine? ( dev-python/PyQtWebEngine[${PYTHON_USEDEP}] )
- )
- pyside2? (
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[designer?,gui?,help?,location?,multimedia?]
- dev-python/pyside2[network?,opengl(+)?,positioning?,printsupport?]
- dev-python/pyside2[sensors?,serialport(+)?,speech?,sql?,svg?]
- dev-python/pyside2[testlib?,webchannel?,webengine?,websockets?]
- dev-python/pyside2[widgets?,x11extras?,xml?,xmlpatterns?]
- declarative? ( dev-python/pyside2[qml,quick] )
- )
-"
-
-# The QtPy testsuite skips tests for bindings that are not installed, so here we
-# ensure that everything is available and all tests are run. Note that not
-# all flags are available in PyQt5/PySide2, so some tests are still skipped.
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[bluetooth,dbus,declarative,designer,gui,help,location]
- dev-python/PyQt5[multimedia,network,opengl,positioning,printsupport]
- dev-python/PyQt5[sensors,serialport,speech(-),sql,svg,testlib,webchannel]
- dev-python/PyQt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- )
- pyside2? (
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
- dev-python/pyside2[location,multimedia,network,opengl(+),positioning]
- dev-python/pyside2[printsupport,qml,quick,script,scripttools,scxml]
- dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
- dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
- dev-python/pyside2[xml,xmlpatterns]
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- default
- # Disale Qt for Python implementations that are not selected
- if ! use pyqt5; then
- sed -i -e "s/from PyQt5.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- fi
- if ! use pyside2; then
- sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide2.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- fi
-
- # Disable outdated PyQt4 and PySide
- sed -i -e "s/from PyQt4.Qt import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PyQt4.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide.QtCore import/raise ImportError #/" qtpy/__init__.py || die
-}
-
-python_test() {
- if use pyqt5; then
- virtx QT_API="pyqt5" epytest
- fi
- if use pyside2; then
- virtx QT_API="pyside2" epytest
- fi
-}
-
-pkg_postinst() {
- if use pyqt5 && use pyside2; then
- ewarn "You have enabled both PyQt5 and PySide2, note that QtPy will default"
- ewarn "to PyQt5 unless the QT_API environment variable overrides this."
- fi
-}