summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-19 02:35:08 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-19 02:35:08 -0400
commit61446bfca57b8601dcc66d44be073b2f7db99f18 (patch)
tree6ad5c6ab40321e1b8e17f89e7d913f94ef182081 /dev-python
parentdev-python/defusedxml: remove old (diff)
downloadgentoo-61446bfca57b8601dcc66d44be073b2f7db99f18.tar.gz
gentoo-61446bfca57b8601dcc66d44be073b2f7db99f18.tar.bz2
gentoo-61446bfca57b8601dcc66d44be073b2f7db99f18.zip
dev-python/dugong: version bump to 3.7.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dugong/Manifest1
-rw-r--r--dev-python/dugong/dugong-3.7.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/dugong/Manifest b/dev-python/dugong/Manifest
index cd83993cfbb9..570d8862d785 100644
--- a/dev-python/dugong/Manifest
+++ b/dev-python/dugong/Manifest
@@ -1 +1,2 @@
DIST dugong-3.7.1.tar.bz2 194243 BLAKE2B a7514f4b515fcd519f5c11b834d44d16cd395d9eada659dd1913bd07a9a072e19f6737a3d702d9ef2a63160eb5452f146a4b04e744610b8f51c9403a648aef9b SHA512 85c276bba85d650bf0baa6257bf0872cb2da546a23d19e0c94cc15c95721a8d9f6392db0e64b38ab2e801803e3ab7908e6a931d18736d33c87138eca35b4f27c
+DIST dugong-3.7.2.tar.bz2 206730 BLAKE2B f362208db26582a1d3681900e99b2143c779d4da1dff9f1a5bc21a2a00fbd0e0c1abb045a60b6cc29d173c0980c42c19f33d091c3b6f300d0e2d85b180b12995 SHA512 00b6d349fa7c5b8a356d663381a39bc40dd42fe9c01a92003c58437f4c4acc31fdde880b743f2c1035016e6f1e1d0f9cf6608832332f3a4a8640bf868680bea6
diff --git a/dev-python/dugong/dugong-3.7.2.ebuild b/dev-python/dugong/dugong-3.7.2.ebuild
new file mode 100644
index 000000000000..e1144b98f8bd
--- /dev/null
+++ b/dev-python/dugong/dugong-3.7.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
+HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}