summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-08 22:29:25 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-09 01:07:09 +0200
commit8567c5e11084b00195d349aaaaa568519349618d (patch)
treeba9ae21930b6727b84c648c87728402ab669d278 /dev-python
parentdev-lang/boogie: bump to 3.3.0 (diff)
downloadgentoo-8567c5e11084b00195d349aaaaa568519349618d.tar.gz
gentoo-8567c5e11084b00195d349aaaaa568519349618d.tar.bz2
gentoo-8567c5e11084b00195d349aaaaa568519349618d.zip
dev-python/ytmusicapi: bump to 1.8.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ytmusicapi/Manifest1
-rw-r--r--dev-python/ytmusicapi/ytmusicapi-1.8.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ytmusicapi/Manifest b/dev-python/ytmusicapi/Manifest
index de58067ac797..845a671224f2 100644
--- a/dev-python/ytmusicapi/Manifest
+++ b/dev-python/ytmusicapi/Manifest
@@ -1 +1,2 @@
DIST ytmusicapi-1.8.1.tar.gz 283291 BLAKE2B e6894c0bede054e41c485ffa86eb6217d09cc3d619d9ec89777f3575325152acfce98467695dcc95d07e8bb4e3cd8de7c93ee9872373db1958eeb1cabe0ead3c SHA512 37b166e550ead565b752e466ab0ec0fd238474f669b79596a3d16626ed2480ecfe0066715c685f39376ed2ea528993ca2a0330b3c4eac9d4fcd096c8d4c20884
+DIST ytmusicapi-1.8.2.tar.gz 284079 BLAKE2B c47560141062bd43af8334132c16d095daa3e8a6accc90f7c2300f602d85627bcefdda6ef05f2371bef11bd33be1f83575cda1b6bd386a0b449f82b9cbfcd8b9 SHA512 6396f1e245bc390251ca37fe896cf41bb0c5608608134a7d8cc07895aca35cb348e18fdd861b830d8efc4399d5931b82e489e734914f9b685606a2bd7af890ea
diff --git a/dev-python/ytmusicapi/ytmusicapi-1.8.2.ebuild b/dev-python/ytmusicapi/ytmusicapi-1.8.2.ebuild
new file mode 100644
index 000000000000..6d163ebd34ae
--- /dev/null
+++ b/dev-python/ytmusicapi/ytmusicapi-1.8.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unofficial API for YouTube Music"
+HOMEPAGE="https://ytmusicapi.readthedocs.io/
+ https://github.com/sigma67/ytmusicapi/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme