summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-16 22:02:02 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-16 22:05:12 +0100
commit90cfe4d5043350e6983b794bb18c76a5e7f929fa (patch)
treea3681bc82b3379bf95be19daa746d2023935f796 /dev-python
parentdev-python/findimports: Bump to 2.2.0 (diff)
downloadgentoo-90cfe4d5043350e6983b794bb18c76a5e7f929fa.tar.gz
gentoo-90cfe4d5043350e6983b794bb18c76a5e7f929fa.tar.bz2
gentoo-90cfe4d5043350e6983b794bb18c76a5e7f929fa.zip
dev-python/nuitka: Bump to 0.6.18.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-0.6.18.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 2ca182924964..ace30bc29ca7 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -3,4 +3,5 @@ DIST Nuitka-0.6.17.7.tar.gz 3150990 BLAKE2B 130c98e0499380591f3d3a4d6acabd396749
DIST Nuitka-0.6.18.1.tar.gz 3688411 BLAKE2B 4ddc98cfb34ff825c628200a72c8cb671a1053c7085a542bf49c96617155c69424b1de924cf6fb7fdaf5a5a52049781f687c1cda909fe4309410296e79f34435 SHA512 3638e6c8dd25a19f69eec3bafed22d758a1ec6c15d0491f91d9c6e5570014b87f6efd6d8944a3e85ade314f49128af8cee15b745e26660cfc466fc22bba3e717
DIST Nuitka-0.6.18.2.tar.gz 3690219 BLAKE2B 416e23500ce7739858e6393eef9783a385229509666c8fd814ce9b4110e77d69d2e7167e89d7db262ee98f60b48f43a07ffec76185154dbc50460623ac84e125 SHA512 7fa6cf48843d45b1d7a1cad11934b5cca2288939e07c12e6916b9c4a37e65d785599ada9e0001faa4117c50e4161fb54253fda27f186f5a660f59810b7254658
DIST Nuitka-0.6.18.3.tar.gz 3690647 BLAKE2B 7ab4fd2b788a63819b3cbd146e8508d781beb14eec3f0fc724fb4eb0e4805fb17917ab685ab2e28ea50d06c4235be1aa05a694b19e1a2cafd8542d8133aa3496 SHA512 b2aa249dff42c17e0f1c6a33e57cb5e40e17f4043c54467af68071e674ccbe01fd446bfce1e4f0488fd0094561c51ed9f1322e73b049ef19c3f2a9d4f0a6fc44
+DIST Nuitka-0.6.18.4.tar.gz 3690751 BLAKE2B 209a7b0d981f9ba777c53b80708e7f5b09e65565246e9d06b7a0ad6155d3cb5b57e2191406e304be585b326a917f8787c4635c326b5e8ad9254d5ade40cf1ec6 SHA512 9cf404e985dcdc11416218e30340c5d52b6a835d1d1a94d9b5cedfcea774abc7ed848a5c4bd5783a9a1898f469e519148ed195945d3d8e7b9043da00ea38c7f0
DIST Nuitka-0.6.18.tar.gz 3687825 BLAKE2B f2c5655c610083065cc205c0a92ff9c57edfc87a479592f435c3dd194e2d6d71ff0ee9866bc97f222b3936190a4420e7d69cf9413b5b2a5e9439448dda82004f SHA512 df4c81d890ce9c5dc24e648f65137d4bb91dcb92917859976a3400ace6c297f985cee4932b50cb3c2aedb2eaa806be7529a98a75a32fe3f59ec718ed3281003b
diff --git a/dev-python/nuitka/nuitka-0.6.18.4.ebuild b/dev-python/nuitka/nuitka-0.6.18.4.ebuild
new file mode 100644
index 000000000000..d42d1b9e532c
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.18.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}