summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-07 03:40:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-07 03:40:43 +0200
commitb4f154a0523762d75a0472d13c4a090a5a083461 (patch)
tree9484bf78558fe87cc9c3b3545666324c8aed79be /dev-python
parentsys-devel/gcc: add 14.0.0_pre20230806 (diff)
downloadgentoo-b4f154a0523762d75a0472d13c4a090a5a083461.tar.gz
gentoo-b4f154a0523762d75a0472d13c4a090a5a083461.tar.bz2
gentoo-b4f154a0523762d75a0472d13c4a090a5a083461.zip
dev-python/libnacl: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/libnacl/Manifest1
-rw-r--r--dev-python/libnacl/libnacl-2.1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/libnacl/Manifest b/dev-python/libnacl/Manifest
index d2d1fa7285f1..2f4089d6027d 100644
--- a/dev-python/libnacl/Manifest
+++ b/dev-python/libnacl/Manifest
@@ -1,3 +1,4 @@
DIST libnacl-1.8.0.gh.tar.gz 43351 BLAKE2B 4ba0ebcb50755d80418ffe7238c65d9309954cb2a0eac61937c488144b56093f3fcd87f0bf22a290c7b415c70cb781fbf7a2c608863d43694230fe34b3ad418e SHA512 7a39d646083591782691c4d58fd4d743b385ee553bcc4c4741707a237fa3b1213629b5070390526175bdfe8436859aa7711779ff8b22a981227edb30b94e82d6
DIST libnacl-1.9.0.gh.tar.gz 43752 BLAKE2B 4a604958aeb9c4b26351b74fa3452b72b7e822c9ea28f4a070464568f1eed184615f0ad5624a2838bf055cf221a9a0f493419b16f2bf2be26c608b396d3f234c SHA512 1c1011f218864f4eab6a985a957f7ec5b8a227ed107ab336a0bc076be10bae6d598f3e81f3a20177e81f25f93c36b23118f515b98f87e11b1f727cae3db1e267
DIST libnacl-2.0.0.gh.tar.gz 44710 BLAKE2B 50fa7d446370bb6043d942b28364b5bf2a23efcd6f3c82a59ee0ef0f7666a9ebe8e3dcf487d43e6ecb548ededb5e6228b3da401dc30924fef90047da40888168 SHA512 f8159ae479d920058662ffde2ac3bad2c8b413d55ca0bd442b81c7071b4cfca90eae277f85e7bf0bb63cd71ee1e0ad4cbbb03468ed55d1bcbe06d2e9a0976b72
+DIST libnacl-2.1.0.tar.gz 42189 BLAKE2B 9b7330ad89ed7ca01f1893deda93fd88011f92b03946a06b5706adf25387db0f664e89fb7a0442d300b47188ec061d220167c694725cd7ec74d14687794b63b2 SHA512 9a3bc2d6d21e982cdd7015daf76beb494c8b969f17a17288a47db5ff545e0a0085e37bb723e92a1919338134be2817b47cd2354f55604ec93e638e243ffa5e1a
diff --git a/dev-python/libnacl/libnacl-2.1.0.ebuild b/dev-python/libnacl/libnacl-2.1.0.ebuild
new file mode 100644
index 000000000000..9b7755e92c75
--- /dev/null
+++ b/dev-python/libnacl/libnacl-2.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python ctypes wrapper for libsodium"
+HOMEPAGE="
+ https://libnacl.readthedocs.io/
+ https://github.com/saltstack/libnacl/
+ https://pypi.org/project/libnacl/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/libsodium
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -p 'test_*.py' tests/ ||
+ die "Tests failed with ${EPYTHON}"
+}