summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-08 04:15:27 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-08 04:15:27 +0200
commitb979c04a6a3c15edcb09b1f72b6a6e4e7b52178a (patch)
tree30810d31fb3b555a54ed1bb60da8d1a8823e8802 /dev-python
parentnet-misc/yt-dlp: add 2024.10.07 (diff)
downloadgentoo-b979c04a6a3c15edcb09b1f72b6a6e4e7b52178a.tar.gz
gentoo-b979c04a6a3c15edcb09b1f72b6a6e4e7b52178a.tar.bz2
gentoo-b979c04a6a3c15edcb09b1f72b6a6e4e7b52178a.zip
dev-python/botocore: Bump to 1.35.35
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.35.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 124ea48d0d06..1a786704091f 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.35.31.gh.tar.gz 13414420 BLAKE2B 942455ccd037fb7cd9142a43cbc316c
DIST botocore-1.35.32.gh.tar.gz 13422242 BLAKE2B d1b553be9301b5c9aa674e9aa32d15b69e3fd56eb9d906fb979967a1df6fbf69fac6795dad133bcaf63c8c955d3f234087a7285ba7f603de83f015fc7fcea1fa SHA512 174bed147fc9708e2c1e500276597396a4f63d0417bfeb6058296a9aaeb6f21a56e8bd63d06248641e99f0e38e1dbc5c1a3ce8c17c28e1c3eea8044f58ce0642
DIST botocore-1.35.33.gh.tar.gz 13432128 BLAKE2B 363eb3dd1f819294ff099a9af0a8deca0078d7d7ec533f3c64a86bc5a0228b7d9180dbbde5ebd8af4e5114373021981c5137ca314ce18773a1339f65506700b0 SHA512 a5a7f3afbb9ded8df9419892427d9c71f281e1f974a5b797405ed564f27f26e9b33580de4d5d2ac96096fff46425a39db2b2ee09718d1db89b3847ed7f53d60c
DIST botocore-1.35.34.gh.tar.gz 13432167 BLAKE2B b39c70faa7312fecc748286162c3b3f21ed56ba705d0f8385a157c25d3d25ceb2d3ca7fb8234372600e5738bc7dd562e67368a863b4853da890009af6fff75ae SHA512 116a5698b1a9e60ea47adb1fe51148c0a5025e8ce940bf5b5c8009e77ea0cc850febc45df9581dda0e2238f2d42f6b8afd674d80e11d88047719874b5cb63198
+DIST botocore-1.35.35.gh.tar.gz 13440561 BLAKE2B 7dedca0fa7e492279f1bc138c7cd4d71a302853d311441f57520bde7643c3f47d7c6952d69f0ac9591f6e639cb22986414a01df626c022dc2c8a84d98804160a SHA512 670301f0a56b6c610d9ace6d36b36f14b62aa74daab3087d2ce24370d27485de17928386a5319f4f4483f88096e2e1f8e71923918511649e20535fe88c1b5b42
diff --git a/dev-python/botocore/botocore-1.35.35.ebuild b/dev-python/botocore/botocore-1.35.35.ebuild
new file mode 100644
index 000000000000..4f1ad852bdc1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.35.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}